28d16d0163dd4693059f3cb3b1c3b91a8823618f
[fedora-specs.git] / nbdkit.spec
1 Name:           nbdkit
2 Version:        0.1.0
3 Release:        1%{?dist}
4 Summary:        NBD server
5
6 License:        BSD
7 URL:            https://github.com/libguestfs/nbdkit
8 Source0:        nbdkit-0.1.0.tar.gz
9
10 BuildRequires:  /usr/bin/pod2man
11
12
13 %description
14 NBD is a protocol for accessing block devices (hard disks and
15 disk-like things) over the network.
16
17 'nbdkit' is a toolkit for creating NBD servers.
18
19 The key features are:
20
21 * Multithreaded NBD server written in C with good performance.
22
23 * Well-documented, simple plugin API with a stable ABI guarantee.
24   Let's you export "unconventional" block devices easily.
25
26 * Liberal license (BSD) allows nbdkit to be linked to proprietary
27   libraries or included in proprietary code.
28
29 Several example plugins are included in the package.
30
31 To develop plugins, install the %{name}-devel package and start by
32 reading the nbdkit(1) and nbdkit-plugin(3) manual pages.
33
34
35 %package devel
36 Summary:        Development files and documentation for %{name}
37 License:        BSD
38
39 Requires:       %{name} = %{version}-%{release}
40
41
42 %description devel
43 This package contains development files and documentation
44 for %{name}.  Install this package if you want to develop
45 plugins for %{name}.
46
47
48 %prep
49 %setup -q
50
51
52 %build
53 %configure --disable-static
54 make %{?_smp_mflags}
55
56
57 %install
58 %make_install
59
60 # Delete libtool crap.
61 find $RPM_BUILD_ROOT -name '*.la' -delete
62
63
64 %files
65 %doc LICENSE README
66 %{_sbindir}/nbdkit
67 %{_libdir}/%{name}
68 %{_mandir}/man1/nbdkit.1*
69 %{_mandir}/man1/libnbdkit-*.1*
70
71
72 %files devel
73 %doc LICENSE README TODO
74 # Include the source of the example plugins in the documentation.
75 %doc plugins/example*/*.c
76 %{_includedir}/nbdkit-plugin.h
77 %{_mandir}/man3/nbdkit-plugin.3*
78
79
80 %changelog
81 * Fri Jun 21 2013 Richard W.M. Jones <rjones@redhat.com> 0.1.0-1
82 - Initial release.