Enable tests
[fedora-reviews.git] / xnvme / xnvme.spec
1 Name:           xnvme
2 Version:        0.7.4
3 Release:        2%{?dist}
4 Summary:        Unified API and tools for traditional and emerging I/O interfaces
5
6 License:        BSD-3-Clause
7 URL:            https://github.com/OpenMPDK/xNVMe
8 Source:         %{url}/releases/download/v%{version}/xnvme-%{version}.tar.gz
9
10 # The package makes 64 bit assumptions so exclude 32 bit i686.
11 # https://fedoraproject.org/wiki/Changes/EncourageI686LeafRemoval
12 ExcludeArch:    %{ix86}
13
14 BuildRequires:  meson
15 BuildRequires:  gcc
16 BuildRequires:  libaio-devel
17 BuildRequires:  liburing-devel
18
19 %description
20 %{summary}.
21 Minimal-overhead libraries and tools for cross-platform storage I/O and
22 NVMe-native development. A unified API encapsulating traditional block-I/O via
23 psync, libaio, and io_uring as well as user-space NVMe drivers.
24
25 %package devel
26 Summary:        Development library and header files for %{name}
27 Requires:       %{name}%{?_isa} = %{version}-%{release}
28
29 %description devel
30 This contains the headers and libraries for developing against %{name}.
31
32 %package static
33 Summary:        Static library for %{name}
34 Requires:       %{name}-devel%{?_isa} = %{version}-%{release}
35
36 %description static
37 %{summary}.
38
39 %package tools
40 Summary:        Command-line tools for storage I/O and NVMe-native development
41 Requires:       %{name}%{?_isa} = %{version}-%{release}
42
43 %description tools
44 %{summary}.
45
46 %prep
47 %autosetup
48
49 %build
50 %meson -Dforce_completions=true -Dwith-libvfn=disabled -Dwith-isal=disabled -Dwith-spdk=false -Dexamples=false -Dtests=false
51 %meson_build
52
53 %install
54 %meson_install
55
56 %check
57 %meson_test
58
59 %files
60 %license LICENSE
61 %{_libdir}/lib%{name}.so.0*
62
63 %files devel
64 %{_libdir}/lib%{name}.so
65 %{_libdir}/pkgconfig/%{name}.pc
66 %{_includedir}/lib%{name}*.h
67
68 %files static
69 %{_libdir}/lib%{name}.a
70
71 %files tools
72 %{_bindir}/kvs
73 %{_bindir}/lblk
74 %{_bindir}/xdd
75 %{_bindir}/%{name}
76 %{_bindir}/%{name}-driver
77 %{_bindir}/%{name}_file
78 %{_bindir}/zoned
79 %{_mandir}/man1/kvs.1*
80 %{_mandir}/man1/kvs-*.1*
81 %{_mandir}/man1/lblk.1*
82 %{_mandir}/man1/lblk-*.1*
83 %{_mandir}/man1/xdd.1*
84 %{_mandir}/man1/xdd-*.1*
85 %{_mandir}/man1/%{name}.1*
86 %{_mandir}/man1/%{name}-*.1*
87 %{_mandir}/man1/%{name}_file.1*
88 %{_mandir}/man1/%{name}_file-*.1*
89 %{_mandir}/man1/zoned.1*
90 %{_mandir}/man1/zoned-*.1*
91 %{_datadir}/bash-completion/completions/kvs-completions
92 %{_datadir}/bash-completion/completions/lblk-completions
93 %{_datadir}/bash-completion/completions/xdd-completions
94 %{_datadir}/bash-completion/completions/%{name}-completions
95 %{_datadir}/bash-completion/completions/%{name}_file-completions
96 %{_datadir}/bash-completion/completions/zoned-completions
97
98 %changelog
99 * Mon Feb 19 2024 Richard W.M. Jones <rjones@redhat.com> - 0.7.4-2
100 - Initial version