Move old opensbi, import opensbi-unstable
[fedora-reviews.git] / opensbi / opensbi.spec
1 # Disable debug packages, we don't need them.
2 %global debug_package %{nil}
3
4 Name:           opensbi-unstable
5 # The last part is short hash
6 # Format: <TAG>.<NUMBER_OF_COMMITS_AFTER_TAG>.<YEAR>.<MONTH>.<DAY>.<SHORT_COMMIT>
7 Version:        v1.2.116.2023.05.02.7919530
8 Release:        1%{?dist}
9 Summary:        RISC-V Open Source Supervisor Binary Interface
10
11 License:        BSD
12 URL:            https://github.com/riscv/opensbi
13
14 # Download tarball, e.g.:
15 # https://github.com/riscv/opensbi/archive/%full_commit.tar.gz
16 %global full_commit 791953030836d39687688a8e7f1a3e708892cfa1
17 Source0:        https://github.com/riscv/opensbi/archive/%{full_commit}.tar.gz
18
19 BuildRequires:  gcc
20 BuildRequires:  binutils
21 BuildRequires:  findutils
22 BuildRequires:  grep
23 BuildRequires:  coreutils
24 BuildRequires:  make
25 BuildRequires:  dtc
26 BuildRequires:  python3
27 BuildRequires:  gawk
28 BuildRequires:  sed
29
30
31 %description
32 RISC-V Open Source Supervisor Binary Interface compiled in jump variant.
33 This is only for QEMU RISC-V virt machine.
34
35
36 %prep
37 %autosetup -n opensbi-%{full_commit}
38
39
40 %build
41 make \
42   PLATFORM=generic
43
44
45 %install
46 make \
47   PLATFORM=generic \
48   I=%{buildroot} \
49   INSTALL_LIB_PATH=lib64 \
50   INSTALL_FIRMWARE_PATH=%{_datadir}/%{name} \
51   install
52
53
54 rm -rfv %{buildroot}/lib64
55 rm -rfv %{buildroot}/include
56 rm -rfv %{buildroot}%{_datadir}/%{name}/*/firmware/payloads
57
58
59 %files
60 %license COPYING.BSD
61 %doc README.md
62 %dir %{_datadir}/%{name}
63 %{_datadir}/%{name}/*
64
65
66 %changelog
67 * Tue May 02 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.2.116.2023.05.02.7919530-1
68 - Sync with upstream master branch (v1.2-116-g7919530)
69
70 * Thu Jan 26 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.2.0.2023.01.26.c6b5188c-1
71 - Use v1.2 (last stable release for now)
72
73 * Tue Jan 25 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.2.34.2023.01.25.c45992c-1
74 - Sync with upstream master branch (v1.2-34-gc45992c)
75
76 * Thu Nov 17 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.1.85.2022.11.17.14f5c4c-1
77 - Sync with upstream master branch (v1.1-85-g14f5c4c)
78
79 * Mon Jun 23 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.1.0.2022.06.27.4489876-1
80 - Sync with upstream master branch (v1.1 tag)
81
82 * Thu Jun 23 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.0.99.2022.06.23.6f1fe98-1
83 - Sync with upstream master branch
84
85 * Thu Jun 02 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.0.92.2022.06.13.9dc5ec5-1
86 - Sync with upstream master branch
87
88 * Thu Jun 02 2022 David Abdurachmanov <davidlt@rivosinc.com> v1.0.81.2022.06.02.cb8271c-1
89 - Sync with upstream master branch
90
91 * Sat Nov 06 2021 David Abdurachmanov <david.abdurachmanov@gmail.com> v0.9.163.2021.11.06.0979ffd-1
92 - Sync with upstream master branch
93
94 * Fri Oct 08 2021 David Abdurachmanov <david.abdurachmanov@gmail.com> v0.9.152.2021.10.08.754d511-1
95 - Sync with upstream master branch
96
97 * Tue Aug 17 2021 David Abdurachmanov <david.abdurachmanov@gmail.com> v0.9.134.2021.08.17.7aa6c9a-1
98 - Sync with upstream master branch
99 - Upstream support for SiFive HiFive Unmatched
100
101 * Wed Apr 21 2021 David Abdurachmanov <david.abdurachmanov@gmail.com> v0.9.35.2021.04.21.f41196a
102 - Update to v0.9+
103
104 * Wed Jan 06 2021 David Abdurachmanov <david.abdurachmanov@sifive.com> v0.8.81.2021.01.06.7dcb1e1
105 - New version
106 - Switch to generic platform
107 - Remove all others special Fedora variants of firmware
108 - Remove development library and documentation (not needed)
109 - Remove example payloads