New patches from Fedora.
[fedora-mingw.git] / qt-win / mingw32-qt-win.spec
index f683582..d75d682 100644 (file)
 #   from the native Fedora package.  The reason is so that we can
 #   set the default include and library paths correctly.
 
-%define subdirs src/corelib src/xml src/network src/gui src/winmain
+%define subdirs src/corelib src/xml src/network src/gui src/winmain src/svg src/sql src/qt3support
 
 Name:           mingw32-qt-win
-Version:        4.4.3
-Release:        2%{?dist}
+Version:        4.5.0
+Release:        1%{?dist}
 Summary:        Qt for Windows
 
-License:        GPLv2+
+License:        GPLv3 with exceptions or LGPLv2 with exceptions
 Group:          Development/Libraries
 
 URL:            http://www.qtsoftware.com/
@@ -44,12 +44,7 @@ Source4:        qplatformdefs.h
 # Generate this patch using "qt-win-configure.sh".
 Patch0:         qt-win-configure.patch
 
-# The released source contains multiple, blatant build bugs which have
-# been fixed (further) upstream months ago.  Urgghhh.  These patches
-# fix them.
-Patch10:        mingw32-qt-4.4.3-atomic-volatile.patch
 Patch11:        mingw32-qt-4.4.3-no-fpu-functions.patch
-Patch12:        mingw32-qt-4.4.3-wininput.patch
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildArch:      noarch
@@ -60,7 +55,11 @@ BuildRequires:  mingw32-gcc-c++
 BuildRequires:  mingw32-binutils
 
 # For the native qmake, moc programs.
+# Note that the precise same native version is required - eg. moc will
+# not work unless it's the same version.
+#BuildRequires:  qt-devel = %{version}  Stupid, can't write this ...
 BuildRequires:  qt-devel
+
 BuildRequires:  zip
 BuildRequires:  dos2unix
 
@@ -83,11 +82,9 @@ Fedora Windows cross-compiler.
 
 %patch0 -p1
 
-%patch10 -p1
 %patch11 -p1
-%patch12 -p1
 
-for f in changes-%{version} LICENSE.GPL2 LICENSE.GPL3 GPL_EXCEPTION_ADDENDUM.TXT GPL_EXCEPTION.TXT OPENSOURCE-NOTICE.TXT README; do
+for f in LICENSE.GPL3 LICENSE.LGPL LGPL_EXCEPTION.txt KNOWN.ISSUES README; do
   dos2unix --keepdate $f
 done
 
@@ -158,26 +155,47 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc changes-%{version} configure.output
-%doc LICENSE.GPL2 LICENSE.GPL3 GPL_EXCEPTION_ADDENDUM.TXT GPL_EXCEPTION.TXT
-%doc OPENSOURCE-NOTICE.TXT README
+%doc configure.output
+%doc LICENSE.GPL3 LICENSE.LGPL LGPL_EXCEPTION.txt KNOWN.ISSUES README
 %{_mingw32_bindir}/QtCore4.dll
 %{_mingw32_bindir}/QtGui4.dll
 %{_mingw32_bindir}/QtNetwork4.dll
 %{_mingw32_bindir}/QtXml4.dll
+%{_mingw32_bindir}/QtSvg4.dll
+%{_mingw32_bindir}/QtSql4.dll
+%{_mingw32_bindir}/Qt3Support4.dll
 %{_mingw32_libdir}/libQtCore4.a
 %{_mingw32_libdir}/libQtGui4.a
 %{_mingw32_libdir}/libQtNetwork4.a
 %{_mingw32_libdir}/libQtXml4.a
+%{_mingw32_libdir}/libQtSvg4.a
+%{_mingw32_libdir}/libQtSql4.a
+%{_mingw32_libdir}/libQt3Support4.a
 %{_mingw32_libdir}/libqtmain.a
 %{_mingw32_includedir}/Qt/
 %{_mingw32_includedir}/QtCore/
 %{_mingw32_includedir}/QtGui/
 %{_mingw32_includedir}/QtNetwork/
 %{_mingw32_includedir}/QtXml/
+%{_mingw32_includedir}/QtSvg/
+%{_mingw32_includedir}/QtSql/
+%{_mingw32_includedir}/Qt3Support/
 %{_libdir}/qt4/mkspecs/fedora-win32-cross
 
 
 %changelog
+* Thu Mar 12 2009 Thomas Sailer <t.sailer@alumni.ethz.ch> - 4.5.0-1
+- update to Qt 4.5.0 (release)
+- also build QtSvg, QtSql, Qt3Support
+
+* Sat Feb 21 2009 Richard W.M. Jones <rjones@redhat.com> - 4.5.0-0.2.rc1
+- Update to Qt 4.5.0-rc1.
+
+* Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 4.4.3-4
+- Rebuild for mingw32-gcc 4.4
+
+* Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 4.4.3-3
+- Fix required for older W32API in Fedora 10.
+
 * Sun Feb  1 2009 Richard W.M. Jones <rjones@redhat.com> - 4.4.3-2
 - Initial RPM release.