Fix zlib to actually use the win32 mingw build instead of generic static only build
[fedora-mingw.git] / libxml2 / mingw-libxml2.spec
index 1651c1c..b12ba95 100644 (file)
@@ -13,6 +13,7 @@ BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildRequires:  mingw-gcc
 BuildRequires:  mingw-binutils
+BuildRequires:  mingw-zlib
 
 Requires:       mingw-runtime
 
@@ -25,7 +26,7 @@ MinGW Windows libxml2 XML processing library.
 
 
 %build
-CFLAGS="$RPM_OPT_FLAGS -fno-stack-protector" \
+CFLAGS="-O2 -g -Wall -pipe" LDFLAGS="-no-undefined" \
 ./configure \
   --build=%_build \
   --host=i686-pc-mingw32 \