Add .gitignore file.
[fedora-mingw.git] / boost / mingw32-boost.spec
index 3e83f69..ebf4f4e 100644 (file)
@@ -6,7 +6,7 @@
 
 Name:           mingw32-boost
 Version:        1.34.1
-Release:        2%{?dist}
+Release:        6%{?dist}
 Summary:        MinGW Windows port of Boost C++ Libraries
 
 License:        Boost
@@ -22,6 +22,9 @@ Patch3:         boost-run-tests.patch
 Patch4:         boost-regex.patch
 Patch5:         boost-gcc43.patch
 
+# For GCC 4.4, https://svn.boost.org/trac/boost/ticket/2069
+Patch1000:      svn-r48960.diff
+
 BuildArch:      noarch
 
 BuildRequires:  mingw32-filesystem >= 30
@@ -55,6 +58,8 @@ Standards Committee's upcoming C++ Standard Library Technical Report.)
 %patch4 -p0
 %patch5 -p1
 
+%patch1000 -p2
+
 
 %build
 BOOST_ROOT=`pwd`
@@ -79,7 +84,7 @@ REGEX_FLAGS="--without-icu"
 rm user-config.jam
 echo "using gcc : : %{_mingw32_cc} : ;" > user-config.jam
 
-make all
+make %{?_smp_mflags} all
 
 
 %install
@@ -135,6 +140,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
+%doc LICENSE_1_0.txt
 %{_mingw32_includedir}/boost
 %{_mingw32_bindir}/libboost_date_time.dll
 %{_mingw32_libdir}/libboost_date_time.dll.a
@@ -185,5 +191,14 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Sat Feb 21 2009 Richard W.M. Jones <rjones@redhat.com> - 1.34.1-6
+- Rebuild for mingw32-gcc 4.4
+
+* Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.34.1-4
+- Include license file.
+
+* Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.34.1-3
+- Use _smp_mflags.
+
 * Sat Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.34.1-2
 - Initial RPM release.