Added ocaml-lablgtk.
[fedora-mingw.git] / runtime / mingw32-runtime.spec
index 016e857..32b73a3 100644 (file)
@@ -6,8 +6,8 @@
 
 Name:           mingw32-runtime
 Version:        3.15.1
-Release:        2%{?dist}
-Summary:        MinGW Windows cross-compiler runtime and root filesystem
+Release:        8%{?dist}
+Summary:        MinGW Windows cross-compiler runtime
 
 License:        Public Domain
 Group:          Development/Libraries
@@ -15,25 +15,18 @@ URL:            http://www.mingw.org/
 Source0:        http://dl.sourceforge.net/sourceforge/mingw/mingwrt-%{version}-mingw32-src.tar.gz
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
-Patch0:         mingw32-runtime-3.15.1-useconds_t.patch
-
 BuildArch:      noarch
 
-BuildRequires:  mingw32-filesystem >= 26
+BuildRequires:  mingw32-filesystem >= 39-3
 BuildRequires:  mingw32-binutils
 BuildRequires:  mingw32-gcc
 
-Requires:       mingw32-filesystem >= 26
 Requires:       mingw32-binutils
 Requires:       mingw32-gcc
 
 # Once this is installed, mingw32-bootstrap (binary bootstrapper) is no
 # longer needed.
 Obsoletes:      mingw32-runtime-bootstrap
-Obsoletes:      mingw-runtime-bootstrap
-
-Provides:       mingw-runtime = %{version}-%{release}
-Obsoletes:      mingw-runtime < 3.14-5
 
 
 %description
@@ -42,28 +35,22 @@ MinGW Windows cross-compiler runtime, base libraries.
 
 %prep
 %setup -q -n mingwrt-%{version}-mingw32
-%patch0 -p1
 
 
 %build
-CFLAGS="-I%{_mingw32_includedir}" \
-./configure \
-  --build=%_build \
-  --host=%{_mingw32_host}
-
-make
+MINGW32_CFLAGS="%{_mingw32_cflags} -I%{_mingw32_includedir}"
+%{_mingw32_configure}
+%{_mingw32_make}
 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make prefix=$RPM_BUILD_ROOT%{_mingw32_prefix} install
+%{_mingw32_makeinstall}
 
 # make install places these in nonstandard locations, so move them.
 mkdir -p $RPM_BUILD_ROOT%{_mingw32_docdir}
 mv $RPM_BUILD_ROOT%{_mingw32_prefix}/doc/* $RPM_BUILD_ROOT%{_mingw32_docdir}/
-mkdir -p $RPM_BUILD_ROOT%{_mingw32_mandir}
-mv $RPM_BUILD_ROOT%{_mingw32_prefix}/man/* $RPM_BUILD_ROOT%{_mingw32_mandir}/
 
 
 %clean
@@ -80,6 +67,25 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Mon Nov 24 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-8
+- Rebuild against latest filesystem package.
+- MINGW_CFLAGS -> MINGW32_CFLAGS.
+- Rewrite the summary for accuracy and brevity.
+
+* Fri Nov 21 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-6
+- Remove obsoletes for a long dead package.
+- Reenable (and fix) _mingw32_configure (Levente Farkas).
+
+* Thu Nov 20 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-5
+- Don't use _mingw32_configure macro - doesn't work here.
+
+* Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-4
+- Rebuild against mingw32-filesystem 37
+
+* Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-3
+- Remove the useconds patch, which is no longer needed (Levente Farkas).
+- Use _mingw32_configure macro.
+
 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-2
 - Rebuild against mingw32-filesystem 36