Update atk to 1.24.0 release
[fedora-mingw.git] / portablexdr / mingw-portablexdr.spec
index a853515..4069ace 100644 (file)
@@ -1,8 +1,12 @@
-%include /usr/lib/rpm/mingw-defs
+%define __strip %{_mingw_strip}
+%define __objdump %{_mingw_objdump}
+%define _use_internal_dependency_generator 0
+%define __find_requires %{_mingw_findrequires}
+%define __find_provides %{_mingw_findprovides}
 
 Name:           mingw-portablexdr
 Version:        4.0.10
-Release:        3%{?dist}
+Release:        4%{?dist}
 Summary:        MinGW Windows PortableXDR XDR / RPC library
 
 License:        LGPLv2+
@@ -13,7 +17,7 @@ BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildArch:      noarch
 
-BuildRequires:  mingw-filesystem >= 19
+BuildRequires:  mingw-filesystem >= 23
 BuildRequires:  mingw-gcc
 BuildRequires:  mingw-binutils
 
@@ -36,6 +40,9 @@ rm -rf $RPM_BUILD_ROOT
 
 make DESTDIR=$RPM_BUILD_ROOT install
 
+# Remove static library.
+rm $RPM_BUILD_ROOT%{_mingw_libdir}/libportablexdr.a
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -44,13 +51,15 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root)
 %{_mingw_bindir}/libportablexdr-0.dll
-%{_mingw_libdir}/libportablexdr.a
 %{_mingw_libdir}/libportablexdr.dll.a
 %{_mingw_libdir}/libportablexdr.la
 %{_mingw_includedir}/rpc
 
 
 %changelog
+* Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-4
+- Remove static library.
+
 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-3
 - Use RPM macros from mingw-filesystem.