Added README.Fedora.
[fedora-mingw.git] / ocaml / mingw32-ocaml.spec
index 174fa64..1cf7874 100644 (file)
@@ -1,10 +1,6 @@
-#%define __strip %{_mingw32_strip}
-#%define __objdump %{_mingw32_objdump}
-%define __strip :
-%define __objdump :
-%define _use_internal_dependency_generator 0
-%define __find_requires %{_mingw32_findrequires}
-%define __find_provides %{_mingw32_findprovides}
+# Built-in strip corrupts binaries, so use the mingw32 strip instead:
+%define __strip %{_mingw32_strip}
+%define __objdump %{_mingw32_objdump}
 
 %define debug_package %{nil}
 
@@ -12,7 +8,7 @@
 
 Name:           mingw32-ocaml
 Version:        3.11.0+beta1
-Release:        10%{?dist}
+Release:        14%{?dist}
 Summary:        Objective Caml MinGW cross-compiler and programming environment
 
 License:        QPL and (LGPLv2+ with exceptions)
@@ -23,6 +19,7 @@ Source0:        http://caml.inria.fr/pub/distrib/ocaml-3.11/ocaml-%{version}.tar
 
 # This is installed as config/Makefile when we cross-compile.
 Source1000:     Makefile-fedora-mingw.in
+Source1001:     README.Fedora
 
 # XXX We should apply any Fedora native patches here.
 
@@ -38,6 +35,10 @@ Patch1006:      mingw32-ocaml-3.11.0+beta1-win32unix-path.patch
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 # Is it noarch? (XXX)
+# Answer: yes and no.  In theory it should be, but because we install
+# Windows binaries in %{_libdir}, the path is different if built on
+# 32 and 64 bit platforms.  We should probably install the binaries
+# in /usr/share.
 BuildArch:      noarch
 
 BuildRequires:  mingw32-filesystem >= 30
@@ -158,6 +159,8 @@ make -C tools ocamlmklib
 # Build ocamlopt
 make opt
 
+cp %{SOURCE1001} .
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -211,6 +214,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
+%doc README.Fedora
 %{_bindir}/%{_mingw32_target}-ocamlc
 %{_bindir}/%{_mingw32_target}-ocamlcp
 %{_bindir}/%{_mingw32_target}-ocamldep
@@ -223,12 +227,18 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
-* Sun Nov 16 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11.0+beta1-10
+* Mon Nov 17 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11.0+beta1-14
+- Added README.Fedora.
+
+* Sun Nov 16 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11.0+beta1-13
 - Build the native compiler as 32 bits even on a 64 bit build
   architecture (because the target, Windows, is 32 bit).  The
   compiler does strength reduction and other optimizations
   internally so we must ensure it uses the same int type.
 - Requires libX11-devel.i386 and libgcc.i386.
+- Allow the normal dependency generators to run because this
+  is a native package.
+- Use mingw32 strip to avoid corrupting binaries.
 
 * Sun Nov 16 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11.0+beta1-8
 - Install ocamlc.