Include a bugfix for GCC 4.4
[fedora-mingw.git] / nsis / mingw32-nsis.spec
index 1c98ecb..76b94d3 100644 (file)
@@ -1,9 +1,10 @@
 %define sconsopts VERSION=%{version} PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} SKIPPLUGINS=System DEBUG_SYMBOLS=1 OPTS=1
+%define _default_patch_fuzz 2
 
 Name:           mingw32-nsis
-Version:        2.39
-Release:        1%{?dist}
-Summary:        MinGW Windows libxml2 XML processing library
+Version:        2.43
+Release:        2%{?dist}
+Summary:        Nullsoft Scriptable Install System
 
 License:        zlib and CPL
 Group:          Development/Libraries
@@ -12,18 +13,24 @@ Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.t
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 # Patches from Debian (mainly by Paul Wise).
-Patch0:         nsis-2.39-debian-64bit-fixes.patch
-Patch1:         nsis-2.39-debian-debug-opt.patch
+Patch0:         nsis-2.42-debian-64bit-fixes.patch
+Patch1:         nsis-2.43-debian-debug-opt.patch
 
-# This patch is required for NSIS to find the correct cross-compiler.
-Patch2:         nsis-2.39-mingw32-search.patch
-
-BuildRequires:  mingw32-filesystem >= 20
+BuildRequires:  mingw32-filesystem >= 40
 BuildRequires:  mingw32-gcc
+BuildRequires:  mingw32-gcc-c++
 BuildRequires:  mingw32-binutils
 BuildRequires:  python
-BuildRequires:  scons >= 0.96.93
-BuildRequires:  wxGTK-devel
+BuildRequires:  scons
+
+# since nsis a 32 bit only apps
+#ExclusiveArch:  %{ix86} ppc
+#BuildRequires:  wxGTK-devel
+# The above is only required for Koji.  In mock we _can_ build on
+# x86_64 provided we have the 32 bit libraries required by the next
+# two lines.
+BuildRequires:  /usr/include/gnu/stubs-32.h
+BuildRequires:  /usr/lib/libwx_baseu-2.8.so
 
 
 %description
@@ -38,9 +45,9 @@ assembler code.
 
 %prep
 %setup -q -n nsis-%{version}-src
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
+
+%patch0 -p1 -b .64bit
+%patch1 -p1 -b .debug
 
 
 %build
@@ -62,12 +69,26 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%{_bindir}/*
-%config(noreplace) %{_sysconfdir}/nsisconf.nsh
-%{_includedir}/nsis
 %doc %{_docdir}/%{name}-%{version}
+%config(noreplace) %{_sysconfdir}/nsisconf.nsh
+%{_bindir}/*
+#{_includedir}/nsis
+%{_datadir}/nsis
 
 
 %changelog
-* Mon Sep 22 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-1
+* Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 2.43-2
+- Rebuild for mingw32-gcc 4.4
+
+* Fri Feb 13 2009 Levente Farkas <lfarkas@lfarkas.org> - 2.43-1
+- update to the latest upstream
+
+* Wed Jan 14 2009 Levente Farkas <lfarkas@lfarkas.org> - 2.42-1
+- update to the latest upstream
+- a few small changes
+
+* Fri Oct 17 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-5
+- Fix the Summary line.
+
+* Wed Oct  8 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-4
 - Initial RPM release.