Don't use RPM_OPT_FLAGS because they add -m64 on x86_64 arch. List all files explicit...
[fedora-mingw.git] / libgpg-error / mingw-libgpg-error.spec
index b946e91..5eac3e7 100644 (file)
@@ -2,7 +2,7 @@
 
 Name:           mingw-libgpg-error
 Version:        1.6
-Release:        1%{?dist}
+Release:        2%{?dist}
 Summary:        MinGW Windows GnuPGP error library
 
 License:        LGPLv2+
@@ -25,7 +25,7 @@ MinGW Windows GnuPGP error library.
 
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" \
+CFLAGS="-O2 -g -Wall -pipe" \
 ./configure \
   --build=%_build \
   --host=i686-pc-mingw32 \
@@ -46,13 +46,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/*
-%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/*
-%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/*
+%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/gpg-error-config
+%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/gpg-error.exe
+%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/libgpg-error-0.dll
+%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/libgpg-error.a
+%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/libgpg-error.dll.a
+%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/libgpg-error.la
+%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/gpg-error.h
 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/aclocal/gpg-error.m4
 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/common-lisp/source/gpg-error/*
 
-
 %changelog
+* Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 1.6-2
+- List files explicitly and use custom CFLAGS
+
 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 1.6-1
 - Initial RPM release, largely based on earlier work from several sources.