Added mingw32-configure script.
[fedora-mingw.git] / filesystem / mingw32-filesystem.spec
index 52fd7a5..7292baa 100644 (file)
@@ -1,7 +1,7 @@
 %define debug_package %{nil}
 
 Name:           mingw32-filesystem
-Version:        30
+Version:        32
 Release:        1%{?dist}
 Summary:        MinGW base filesystem and environment
 
@@ -17,11 +17,25 @@ Source2:        mingw32.sh
 Source3:        mingw32.csh
 Source4:        mingw32-find-requires.sh
 Source5:        mingw32-find-provides.sh
+Source6:        mingw32-configure.sh
 
 Requires:       setup
 Requires:       rpm
 
-# These are actually provided by Windows itself, or Wine.
+# Note about 'Provides: mingw32(foo.dll)'
+# ------------------------------------------------------------
+#
+# We want to be able to build & install mingw32 libraries without
+# necessarily needing to install wine.  (And certainly not needing to
+# install Windows!)  There is no requirement to have wine installed in
+# order to use the mingw toolchain to develop software (ie. to
+# compile more stuff on top of it), so why require that?
+#
+# So for expediency, this base package provides the "missing" DLLs
+# from Windows.  Another way to do it would be to exclude these
+# proprietary DLLs in our find-requires checking script - essentially
+# it comes out the same either way.
+#
 Provides:       mingw32(gdi32.dll)
 Provides:       mingw32(kernel32.dll)
 Provides:       mingw32(ole32.dll)
@@ -57,6 +71,9 @@ rm -rf $RPM_BUILD_ROOT
 
 mkdir -p $RPM_BUILD_ROOT
 
+mkdir -p $RPM_BUILD_ROOT%{_bindir}
+install -m 755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/mingw32-configure
+
 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
 install -m 644 %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
 
@@ -112,11 +129,19 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %{_sysconfdir}/rpm/macros.mingw32
 %config(noreplace) %{_sysconfdir}/profile.d/mingw32.sh
 %config(noreplace) %{_sysconfdir}/profile.d/mingw32.csh
+%{_bindir}/mingw32-configure
 %{_prefix}/i686-pc-mingw32/
 /usr/lib/rpm/mingw32-*
 
 
 %changelog
+* Mon Oct 27 2008 Richard Jones <rjones@redhat.com> - 32-1
+- Add mingw32-configure script.
+
+* Mon Oct 27 2008 Richard Jones <rjones@redhat.com> - 31-1
+- Update the spec file with explanation of the 'Provides: mingw32(...)'
+  lines for Windows system DLLs.
+
 * Mon Oct  6 2008 Richard Jones <rjones@redhat.com> - 30-1
 - Added _mingw32_cxx.