Add macros for find-provides/requires scripts
[fedora-mingw.git] / filesystem / mingw-filesystem.spec
index c91e5a9..dd386e6 100644 (file)
@@ -1,7 +1,7 @@
 %define debug_package %{nil}
 
 Name:           mingw-filesystem
-Version:        2
+Version:        23
 Release:        1%{?dist}
 Summary:        MinGW base filesystem and environment
 
@@ -15,10 +15,20 @@ Source0:        mingw-COPYING
 Source1:        mingw-macros.mingw
 Source2:        mingw.sh
 Source3:        mingw.csh
+Source4:        mingw-find-requires.sh
+Source5:        mingw-find-provides.sh
+Source6:        mingw-defs
 
 Requires:       setup
 Requires:       rpm
 
+# These are actually provided by Windows itself, or Wine.
+Provides:       mingw(msvcrt.dll)
+Provides:       mingw(kernel32.dll)
+Provides:       mingw(user32.dll)
+Provides:       mingw(gdi32.dll)
+Provides:       mingw(ole32.dll)
+
 
 %description
 This package contains the base filesystem layout, RPM macros and
@@ -32,6 +42,7 @@ This environment is maintained by the Fedora MinGW SIG at:
 %prep
 %setup -q -c -T
 cp %{SOURCE0} COPYING
+sed 's/@VERSION@/%{version}/' < %{SOURCE4} > mingw-find-requires.sh
 
 
 %build
@@ -76,6 +87,12 @@ mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man/man{
 # /usr/i686-pc-mingw32/sys-root/mingw/doc
 # but these are both packaging bugs.
 
+# NB. NOT libdir
+mkdir -p $RPM_BUILD_ROOT/usr/lib/rpm
+install -m 0755 mingw-find-requires.sh $RPM_BUILD_ROOT/usr/lib/rpm
+install -m 0755 %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/rpm
+install -m 0644 %{SOURCE6} $RPM_BUILD_ROOT/usr/lib/rpm
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -88,9 +105,51 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %{_sysconfdir}/profile.d/mingw.sh
 %config(noreplace) %{_sysconfdir}/profile.d/mingw.csh
 %{_prefix}/i686-pc-mingw32/
+/usr/lib/rpm/mingw-*
 
 
 %changelog
+* Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 23-1
+- Add macros for find-provides/requires scripts
+
+* Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 22-1
+- Windows provides OLE32.DLL.
+
+* Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 21-1
+- Allow '.' in dll names for find-requires
+- Windows provides GDI32.DLL.
+
+* Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 20-1
+- On 64 bit install in /usr/lib/rpm always.
+
+* Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 19-1
+- 'user32.dll' is provided by Windows.
+- Allow '-' in DLL names.
+- More accurate detection of DLLs in requires/provides scripts.
+
+* Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 17-1
+- Automatically add mingw-filesystem and mingw-runtime requires.
+- Add --prefix to _mingw_configure macro.
+- Three backslashes required on each continuation line in RPM macros.
+
+* Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 14-1
+- Fix path to mingw-find-requires/provides scripts.
+
+* Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 12-1
+- Put CFLAGS on a single line to avoid problems in some configure scripts.
+
+* Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 10-1
+- Provides certain base Windows DLLs (not literally).
+
+* Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 9-1
+- Include RPM dependency generators and definitions.
+
+* Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 4-1
+- Add _mingw_cc/cflags/etc. and _mingw_configure macros.
+
+* Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3-1
+- Add _mingw_host macro.
+
 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 2-1
 - Add _mingw_sysroot macro.
 - Add _mingw_target macro.