Packaging guidelines, renamed example package.
[fedora-mingw.git] / example / mingw32-example.spec
diff --git a/example/mingw32-example.spec b/example/mingw32-example.spec
new file mode 100644 (file)
index 0000000..8b04aa0
--- /dev/null
@@ -0,0 +1,60 @@
+%define __strip %{_mingw32_strip}
+%define __objdump %{_mingw32_objdump}
+%define _use_internal_dependency_generator 0
+%define __find_requires %{_mingw32_findrequires}
+%define __find_provides %{_mingw32_findprovides}
+
+Name:           mingw32-example
+Version:        1.2.3
+Release:        1%{?dist}
+Summary:        
+
+License:        LGPLv2+
+Group:          Development/Libraries
+URL:            
+Source0:        
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch:      noarch
+
+BuildRequires:  mingw32-filesystem >= 23
+BuildRequires:  mingw32-gcc
+BuildRequires:  mingw32-binutils
+# Any additional BuildRequires.
+
+
+%description
+# description
+
+
+%prep
+%setup -q
+
+
+%build
+%{_mingw32_configure}
+make
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make DESTDIR=$RPM_BUILD_ROOT install
+
+# Remove static libraries but DON'T remove *.dll.a files.
+rm $RPM_BUILD_ROOT%{mingw32_libdir}/libfoo.a
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root)
+%{_mingw32_bindir}/foo.dll
+%{_mingw32_libdir}/foo.dll.a
+# etc.
+
+
+%changelog
+* Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.2.3-1
+- Initial RPM release.