1fd0dd497265398d6cb3897c550aaba6c14dc429
[fedora-mingw.git] / xqilla / mingw32-xqilla.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-xqilla
8 Version:        2.1.3
9 Release:        1%{?dist}
10 Summary:        XQilla is an XQuery and XPath 2.0 library, built on top of Xerces-C
11
12 License:        ASL 2.0
13 Group:          Development/Libraries
14
15 URL:            http://xqilla.sourceforge.net/HomePage
16 Source0:        http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
17 Source1:        http://www.apache.org/dist/xerces/c/2/sources/xerces-c-src_2_8_0.tar.gz
18
19 Patch1:         xqilla-xercesc-libdir.patch
20
21 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22 BuildArch:      noarch
23
24 BuildRequires:  mingw32-filesystem >= 35
25 BuildRequires:  mingw32-gcc
26 BuildRequires:  mingw32-gcc-c++
27 BuildRequires:  mingw32-binutils
28
29 BuildRequires:  mingw32-xerces-c >= 2.8.0
30 BuildRequires:  autoconf, automake, libtool
31 BuildRequires:  doxygen, graphviz
32
33 %define xercesc_dir xerces-c-src_2_8_0
34 %define xercesc_build_root %{_builddir}/%{xercesc_dir}
35
36
37 %description
38 XQilla is an XQuery and XPath 2.0 implementation written in C++ and based
39 on Xerces-C. It implements the DOM 3 XPath API, as well as having it's own
40 more powerful API. It conforms to the W3C proposed recomendation of XQuery
41 and XPath 2.0.
42
43
44 %prep
45 %setup -q -b 1 -n XQilla-%{version}
46 %patch1
47
48
49 %build
50 rm -f aclocal.m4
51 aclocal
52 libtoolize --force --copy
53 automake --add-missing --copy --force
54 autoconf
55
56 %{_mingw32_configure} \
57   --disable-static \
58   --disable-rpath \
59   --with-xerces=%{xercesc_build_root}
60 make %{?_smp_mflags}
61
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 export CPPROG="cp -p"
67 make install DESTDIR=$RPM_BUILD_ROOT
68 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' ';'
69 mkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}
70 cp -pr ChangeLog LICENSE $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}
71 cp -pr docs/dom3-api docs/simple-api \
72         $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}
73 for file in `find $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}`; do\
74         if ! [ -s "$file" ]; then rm -f "$file"; fi;
75 done
76
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81
82 %files
83 %defattr(-,root,root)
84 %doc LICENSE
85 %{_mingw32_bindir}/foo.dll
86 %{_mingw32_libdir}/foo.dll.a
87
88
89 %changelog
90 * Wed Feb 18 2009 Richard W.M. Jones <rjones@redhat.com> - 2.1.3-1
91 - Initial RPM release.