d09da9a58cc23a43c4baea0ece94ef63d723b10c
[fedora-mingw.git] / w32api / mingw-w32api.spec
1 %include /usr/lib/rpm/mingw-defs
2
3 Name:           mingw-w32api
4 Version:        3.11
5 Release:        3%{?dist}
6 Summary:        MinGW Windows cross-compiler Win32 header files
7
8 License:        Public Domain
9 Group:          Development/Libraries
10 URL:            http://www.mingw.org/
11 Source0:        http://dl.sourceforge.net/sourceforge/mingw/w32api-%{version}-src.tar.gz
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 BuildArch:      noarch
15
16 BuildRequires:  mingw-filesystem >= 3
17 BuildRequires:  mingw-binutils
18 BuildRequires:  mingw-gcc
19 BuildRequires:  mingw-runtime
20
21 Requires:       mingw-filesystem >= 3
22 Requires:       mingw-binutils
23 Requires:       mingw-gcc
24 Requires:       mingw-runtime
25
26 # Once this is installed, mingw-bootstrap (binary bootstrapper) is no
27 # longer needed.
28 Obsoletes:      mingw-bootstrap
29
30 #%define _use_internal_dependency_generator 0
31 #%define __debug_install_post %{nil}
32
33 # Fake provides, because wine/windows provides this, we don't have
34 # a real dep we can use
35 Provides: mingw(gdi32.dll)
36 Provides: mingw(ole32.dll)
37
38 %description
39 MinGW Windows cross-compiler Win32 header files.
40
41
42 %prep
43 %setup -q -n w32api-%{version}
44
45 %build
46 ./configure \
47   --build=%_build \
48   --host=%{_mingw_host}
49
50 make
51
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 make prefix=$RPM_BUILD_ROOT%{_mingw_prefix} install
57
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62
63 %files
64 %defattr(-,root,root)
65 %{_mingw_includedir}/*
66 %{_mingw_libdir}/*
67
68 %changelog
69 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-3
70 - Use the RPM macros from mingw-filesystem.
71
72 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-2
73 - Initial RPM release, largely based on earlier work from several sources.