Rename implibs as lib*.dll.a for compatibility with libtool
[fedora-mingw.git] / runtime / mingw32-runtime.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-runtime
8 Version:        3.15.1
9 Release:        6%{?dist}
10 Summary:        MinGW Windows cross-compiler runtime and root filesystem
11
12 License:        Public Domain
13 Group:          Development/Libraries
14 URL:            http://www.mingw.org/
15 Source0:        http://dl.sourceforge.net/sourceforge/mingw/mingwrt-%{version}-mingw32-src.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 37
21 BuildRequires:  mingw32-binutils
22 BuildRequires:  mingw32-gcc
23
24 Requires:       mingw32-binutils
25 Requires:       mingw32-gcc
26
27 # Once this is installed, mingw32-bootstrap (binary bootstrapper) is no
28 # longer needed.
29 Obsoletes:      mingw32-runtime-bootstrap
30
31
32 %description
33 MinGW Windows cross-compiler runtime, base libraries.
34
35
36 %prep
37 %setup -q -n mingwrt-%{version}-mingw32
38
39
40 %build
41 MINGW_CFLAGS="%{_mingw32_cflags} -I%{_mingw32_includedir}"
42 %{_mingw32_configure}
43 %{_mingw32_make}
44
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{_mingw32_makeinstall}
50
51 # make install places these in nonstandard locations, so move them.
52 mkdir -p $RPM_BUILD_ROOT%{_mingw32_docdir}
53 mv $RPM_BUILD_ROOT%{_mingw32_prefix}/doc/* $RPM_BUILD_ROOT%{_mingw32_docdir}/
54
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59
60 %files
61 %defattr(-,root,root)
62 %{_mingw32_bindir}/*
63 %{_mingw32_docdir}/*
64 %{_mingw32_includedir}/*
65 %{_mingw32_libdir}/*
66 %{_mingw32_mandir}/man3/*
67
68
69 %changelog
70 * Fri Nov 21 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-6
71 - Remove obsoletes for a long dead package.
72 - Reenable (and fix) _mingw32_configure (Levente Farkas).
73
74 * Thu Nov 20 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-5
75 - Don't use _mingw32_configure macro - doesn't work here.
76
77 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-4
78 - Rebuild against mingw32-filesystem 37
79
80 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-3
81 - Remove the useconds patch, which is no longer needed (Levente Farkas).
82 - Use _mingw32_configure macro.
83
84 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-2
85 - Rebuild against mingw32-filesystem 36
86
87 * Thu Oct 16 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-1
88 - New upstream version 3.15.1.
89
90 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-6
91 - Rename mingw -> mingw32.
92
93 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-4
94 - Use RPM macros from mingw-filesystem.
95
96 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-2
97 - Initial RPM release, largely based on earlier work from several sources.