Revert: Don't use _mingw32_configure macro - doesn't work here.
[fedora-mingw.git] / runtime / mingw32-runtime.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-runtime
8 Version:        3.15.1
9 Release:        5%{?dist}
10 Summary:        MinGW Windows cross-compiler runtime and root filesystem
11
12 License:        Public Domain
13 Group:          Development/Libraries
14 URL:            http://www.mingw.org/
15 Source0:        http://dl.sourceforge.net/sourceforge/mingw/mingwrt-%{version}-mingw32-src.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 26
21 BuildRequires:  mingw32-binutils
22 BuildRequires:  mingw32-gcc
23
24 Requires:       mingw32-filesystem >= 26
25 Requires:       mingw32-binutils
26 Requires:       mingw32-gcc
27
28 # Once this is installed, mingw32-bootstrap (binary bootstrapper) is no
29 # longer needed.
30 Obsoletes:      mingw32-runtime-bootstrap
31 Obsoletes:      mingw-runtime-bootstrap
32
33 Provides:       mingw-runtime = %{version}-%{release}
34 Obsoletes:      mingw-runtime < 3.14-5
35
36
37 %description
38 MinGW Windows cross-compiler runtime, base libraries.
39
40
41 %prep
42 %setup -q -n mingwrt-%{version}-mingw32
43
44
45 %build
46 # NB: Do not use _mingw32_configure here as it won't work.
47 CFLAGS="-I%{_mingw32_includedir}" \
48 ./configure \
49   --build=%_build \
50   --host=%{_mingw32_host}
51 make
52
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 make prefix=$RPM_BUILD_ROOT%{_mingw32_prefix} install
58
59 # make install places these in nonstandard locations, so move them.
60 mkdir -p $RPM_BUILD_ROOT%{_mingw32_docdir}
61 mv $RPM_BUILD_ROOT%{_mingw32_prefix}/doc/* $RPM_BUILD_ROOT%{_mingw32_docdir}/
62 mkdir -p $RPM_BUILD_ROOT%{_mingw32_mandir}
63 mv $RPM_BUILD_ROOT%{_mingw32_prefix}/man/* $RPM_BUILD_ROOT%{_mingw32_mandir}/
64
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69
70 %files
71 %defattr(-,root,root)
72 %{_mingw32_bindir}/*
73 %{_mingw32_docdir}/*
74 %{_mingw32_includedir}/*
75 %{_mingw32_libdir}/*
76 %{_mingw32_mandir}/man3/*
77
78
79 %changelog
80 * Thu Nov 20 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-5
81 - Don't use _mingw32_configure macro - doesn't work here.
82
83 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-4
84 - Rebuild against mingw32-filesystem 37
85
86 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-3
87 - Remove the useconds patch, which is no longer needed (Levente Farkas).
88 - Use _mingw32_configure macro.
89
90 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-2
91 - Rebuild against mingw32-filesystem 36
92
93 * Thu Oct 16 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-1
94 - New upstream version 3.15.1.
95
96 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-6
97 - Rename mingw -> mingw32.
98
99 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-4
100 - Use RPM macros from mingw-filesystem.
101
102 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-2
103 - Initial RPM release, largely based on earlier work from several sources.