28931c3dbe0911362f5b00306b90a36e0ae7ced5
[fedora-mingw.git] / portablexdr / mingw-portablexdr.spec
1 %define __os_install_post /usr/lib/rpm/brp-compress %{nil}
2
3 Name:           mingw-portablexdr
4 Version:        4.0.9
5 Release:        2%{?dist}
6 Summary:        MinGW Windows PortableXDR XDR / RPC library
7
8 License:        LGPLv2+
9 Group:          Development/Libraries
10 URL:            http://et.redhat.com/~rjones/portablexdr/
11 Source0:        http://et.redhat.com/~rjones/portablexdr/portablexdr-%{version}.tar.gz
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 BuildRequires:  mingw-gcc
15 BuildRequires:  mingw-binutils
16
17 Requires:       mingw-runtime
18
19 %description
20 MinGW Windows PortableXDR XDR / RPC library.
21
22
23 %prep
24 %setup -q -n portablexdr-%{version}
25
26
27 %build
28 CFLAGS="$RPM_OPT_FLAGS -fno-stack-protector" \
29 ./configure \
30   --build=%_build \
31   --host=i686-pc-mingw32 \
32   --prefix=%{_prefix}/i686-pc-mingw32/sys-root/mingw
33
34 make
35
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 make DESTDIR=$RPM_BUILD_ROOT install
41
42 # Header files aren't installed by default, install them by hand.
43 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/rpc
44 install -m 0644 rpc/*.h \
45   $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/rpc
46
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51
52 %files
53 %defattr(-,root,root)
54 %{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/*
55 %{_prefix}/i686-pc-mingw32/sys-root/mingw/include/rpc
56
57
58 %changelog
59 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.9-2
60 - Initial RPM release, largely based on earlier work from several sources.