1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
10 Summary: MinGW Windows C++ libraries for network-centric applications
13 Group: Development/Libraries
14 URL: http://pocoproject.org/
15 Source0: http://prdownloads.sourceforge.net/poco/poco-%{version}.tar.bz2
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18 Patch1001: poco-01-buildsystem.patch
19 Patch1002: poco-02-makefiles.patch
20 Patch1003: poco-03-memcpy.patch
24 BuildRequires: mingw32-filesystem >= 33
25 BuildRequires: mingw32-gcc
26 BuildRequires: mingw32-gcc-c++
27 BuildRequires: mingw32-binutils
28 BuildRequires: mingw32-openssl
32 POCO, the C++ Portable Components, is a collection of open source C++
33 class libraries that simplify and accelerate the development of
34 network-centric, portable applications in C++. The libraries integrate
35 perfectly with the C++ Standard Library and fill many of the
36 functional gaps left open by it. Their modular and efficient design
37 and implementation makes the C++ Portable Components extremely well
38 suited for embedded development, an area where the C++ programming
39 language is becoming increasingly popular, due to its suitability for
40 both low-level (device I/O, interrupt handlers, etc.) and high-level
41 object-oriented development. Of course, POCO is also ready for
42 enterprise-level challenges.
44 The POCO libraries free developers from re-inventing the wheel, and
45 allow them to spend their time on more worthwhile areas, such as
46 getting things done quickly and working on the features that make
47 their application unique.
51 %setup -q -n poco-%{version}
53 cp build/config/MinGW build/config/MinGW-cross
60 ./configure --config=MinGW-cross --prefix=%{_mingw32_prefix}
65 rm -rf $RPM_BUILD_ROOT
66 make DESTDIR=$RPM_BUILD_ROOT install
68 # *.dll files should be installed in %{_mingw32_bindir}.
69 mkdir -p $RPM_BUILD_ROOT%{_mingw32_bindir}
70 mv $RPM_BUILD_ROOT%{_mingw32_libdir}/*.dll $RPM_BUILD_ROOT%{_mingw32_bindir}/
74 rm -rf $RPM_BUILD_ROOT
79 # XXX I think the '*d.dll' libraries are debug versions and
80 # possibly they should be moved to a subpackage?
81 %{_mingw32_bindir}/libPocoFoundationd.dll
82 %{_mingw32_bindir}/libPocoFoundation.dll
83 %{_mingw32_bindir}/libPocoNetd.dll
84 %{_mingw32_bindir}/libPocoNet.dll
85 %{_mingw32_bindir}/libPocoUtild.dll
86 %{_mingw32_bindir}/libPocoUtil.dll
87 %{_mingw32_bindir}/libPocoXMLd.dll
88 %{_mingw32_bindir}/libPocoXML.dll
89 %{_mingw32_libdir}/libPocoFoundationd.dll.a
90 %{_mingw32_libdir}/libPocoFoundation.dll.a
91 %{_mingw32_libdir}/libPocoNetd.dll.a
92 %{_mingw32_libdir}/libPocoNet.dll.a
93 %{_mingw32_libdir}/libPocoUtild.dll.a
94 %{_mingw32_libdir}/libPocoUtil.dll.a
95 %{_mingw32_libdir}/libPocoXMLd.dll.a
96 %{_mingw32_libdir}/libPocoXML.dll.a
97 %{_mingw32_includedir}/Poco
101 * Sat Nov 8 2008 Richard W.M. Jones <rjones@redhat.com> - 1.3.3p1-1
102 - Initial RPM release.