* Fri Feb 20 2009 Erik van Pienbroek <info@nntpgrab.nl> - 1.22.1-6
[fedora-mingw.git] / pango / mingw32-pango.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-pango
8 Version:        1.22.1
9 Release:        6%{?dist}
10 Summary:        MinGW Windows Pango library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.pango.org
15 Source0:        http://download.gnome.org/sources/pango/1.21/pango-%{version}.tar.bz2
16
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19 # Native pango uses a %post script to generate this, but the
20 # pango-querymodules.exe binary is not something we can easily run on
21 # a Linux host. We could use wine but wine isn't happy in a mock
22 # environment. So we just include a pre-generated copy on basis that
23 # it won't ever change much.
24 #
25 # If you want to rebuild this, do:
26 # wine %{_mingw32_bindir}/pango-querymodules.exe > pango.modules
27 Source1:        pango.modules
28
29 Patch1000:      pango_enable_static_build.patch
30
31 BuildArch:      noarch
32
33 BuildRequires:  mingw32-filesystem >= 23
34 BuildRequires:  mingw32-gcc
35 BuildRequires:  mingw32-binutils
36 BuildRequires:  mingw32-iconv
37 BuildRequires:  mingw32-gettext
38 BuildRequires:  mingw32-cairo >= 1.8.0
39 BuildRequires:  mingw32-freetype
40 BuildRequires:  mingw32-fontconfig
41 BuildRequires:  mingw32-glib2
42 BuildRequires:  pkgconfig
43
44 # These are required for the patch
45 BuildRequires:  autoconf, automake, libtool
46
47 Requires:       pkgconfig
48
49
50 %description
51 MinGW Windows Pango library.
52
53
54 %package static
55 Summary:        Static version of the MinGW Windows Pango library
56 Requires:       %{name} = %{version}-%{release}
57 Group:          Development/Libraries
58
59 %description static
60 Static version of the MinGW Windows Pango library.
61
62
63 %prep
64 %setup -q -n pango-%{version}
65 %patch1000
66
67 # Regenerate the configure script
68 autoreconf --install --force
69 libtoolize --install --force
70
71 %build
72 # Need to run the correct version of glib-mkenums.
73 PATH=%{_mingw32_bindir}:$PATH \
74 %{_mingw32_configure} --enable-static --enable-shared
75 make %{?_smp_mflags}
76
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 make DESTDIR=$RPM_BUILD_ROOT install
82
83 mkdir -p $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
84 cp %{SOURCE1} $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
85
86 rm -f $RPM_BUILD_ROOT/%{_mingw32_libdir}/charset.alias
87
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(-,root,root,-)
94 %doc COPYING
95 %{_mingw32_bindir}/libpango-1.0-0.dll
96 %{_mingw32_bindir}/libpangocairo-1.0-0.dll
97 %{_mingw32_bindir}/libpangoft2-1.0-0.dll
98 %{_mingw32_bindir}/libpangowin32-1.0-0.dll
99 %{_mingw32_bindir}/pango-querymodules.exe
100 %{_mingw32_includedir}/pango-1.0/
101 %{_mingw32_libdir}/libpango-1.0.dll.a
102 %{_mingw32_libdir}/libpango-1.0.la
103 %{_mingw32_libdir}/libpangocairo-1.0.dll.a
104 %{_mingw32_libdir}/libpangocairo-1.0.la
105 %{_mingw32_libdir}/libpangoft2-1.0.dll.a
106 %{_mingw32_libdir}/libpangoft2-1.0.la
107 %{_mingw32_libdir}/libpangowin32-1.0.dll.a
108 %{_mingw32_libdir}/libpangowin32-1.0.la
109 %{_mingw32_libdir}/pango-1.0.def
110 %{_mingw32_libdir}/pangocairo-1.0.def
111 %{_mingw32_libdir}/pangoft2-1.0.def
112 %{_mingw32_libdir}/pangowin32-1.0.def
113 %dir %{_mingw32_libdir}/pango
114 %dir %{_mingw32_libdir}/pango/1.6.0
115 %dir %{_mingw32_libdir}/pango/1.6.0/modules
116 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.dll
117 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.dll.a
118 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.la
119 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.dll
120 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.dll.a
121 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.la
122 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.dll
123 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.dll.a
124 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.la
125 %{_mingw32_libdir}/pkgconfig/pango.pc
126 %{_mingw32_libdir}/pkgconfig/pangocairo.pc
127 %{_mingw32_libdir}/pkgconfig/pangoft2.pc
128 %{_mingw32_libdir}/pkgconfig/pangowin32.pc
129 %{_mingw32_datadir}/gtk-doc/html/pango/
130 %{_mingw32_mandir}/man1/pango-querymodules.1*
131 %{_mingw32_sysconfdir}/pango/
132
133
134 %files static
135 %defattr(-,root,root,-)
136 %{_mingw32_libdir}/libpango-1.0.a
137 %{_mingw32_libdir}/libpangocairo-1.0.a
138 %{_mingw32_libdir}/libpangoft2-1.0.a
139 %{_mingw32_libdir}/libpangowin32-1.0.a
140 %{_mingw32_libdir}/pango/1.6.0/modules/pango-basic-win32.a
141 %{_mingw32_libdir}/pango/1.6.0/modules/pango-arabic-lang.a
142 %{_mingw32_libdir}/pango/1.6.0/modules/pango-indic-lang.a
143   
144
145 %changelog
146 * Fri Feb 20 2009 Erik van Pienbroek <info@nntpgrab.nl> - 1.22.1-6
147 - Added -static subpackage
148
149 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-5
150 - Rebuild for mingw32-gcc 4.4
151
152 * Fri Jan 30 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-4
153 - Requires pkgconfig.
154
155 * Tue Jan 27 2009 Levente Farkas <lfarkas@lfarkas.org> - 1.22.1-3
156 - Include license file in documentation section.
157
158 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-2
159 - Disable static libraries.
160 - Use _smp_mflags.
161
162 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-1
163 - New upstream version 1.22.1.
164 - BR cairo >= 1.8.0 because of important fixes.
165
166 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-6
167 - Rename mingw -> mingw32.
168
169 * Tue Sep 23 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-5
170 - Remove use of wine in %-post.
171
172 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-4
173 - Add dep on pkgconfig
174
175 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-3
176 - post/preun scripts to update the pango.modules list.
177
178 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-2
179 - Run the correct glib-mkenums.
180
181 * Tue Sep  9 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-1
182 - Initial RPM release