Include license file in documentation section.
[fedora-mingw.git] / pango / mingw32-pango.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-pango
8 Version:        1.22.1
9 Release:        3%{?dist}
10 Summary:        MinGW Windows Pango library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.pango.org
15 Source0:        http://download.gnome.org/sources/pango/1.21/pango-%{version}.tar.bz2
16
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19 # Native pango uses a %post script to generate this, but the
20 # pango-querymodules.exe binary is not something we can easily run on
21 # a Linux host. We could use wine but wine isn't happy in a mock
22 # environment. So we just include a pre-generated copy on basis that
23 # it won't ever change much.
24 #
25 # If you want to rebuild this, do:
26 # wine %{_mingw32_bindir}/pango-querymodules.exe > pango.modules
27 Source1:        pango.modules
28
29 BuildArch:      noarch
30
31 BuildRequires:  mingw32-filesystem >= 23
32 BuildRequires:  mingw32-gcc
33 BuildRequires:  mingw32-binutils
34 BuildRequires:  mingw32-iconv
35 BuildRequires:  mingw32-gettext
36 BuildRequires:  mingw32-cairo >= 1.8.0
37 BuildRequires:  mingw32-freetype
38 BuildRequires:  mingw32-fontconfig
39 BuildRequires:  mingw32-glib2
40 BuildRequires:  pkgconfig
41
42 %description
43 MinGW Windows Pango library.
44
45
46 %prep
47 %setup -q -n pango-%{version}
48
49 %build
50 # Need to run the correct version of glib-mkenums.
51 PATH=%{_mingw32_bindir}:$PATH \
52 %{_mingw32_configure} --disable-static
53 make %{?_smp_mflags}
54
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61 mkdir -p $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
62 cp %{SOURCE1} $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
63
64 rm -f $RPM_BUILD_ROOT/%{_mingw32_libdir}/charset.alias
65
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(-,root,root)
72 %doc COPYING
73 %{_mingw32_bindir}/libpango-1.0-0.dll
74 %{_mingw32_bindir}/libpangocairo-1.0-0.dll
75 %{_mingw32_bindir}/libpangoft2-1.0-0.dll
76 %{_mingw32_bindir}/libpangowin32-1.0-0.dll
77 %{_mingw32_bindir}/pango-querymodules.exe
78 %{_mingw32_includedir}/pango-1.0/
79 %{_mingw32_libdir}/libpango-1.0.dll.a
80 %{_mingw32_libdir}/libpango-1.0.la
81 %{_mingw32_libdir}/libpangocairo-1.0.dll.a
82 %{_mingw32_libdir}/libpangocairo-1.0.la
83 %{_mingw32_libdir}/libpangoft2-1.0.dll.a
84 %{_mingw32_libdir}/libpangoft2-1.0.la
85 %{_mingw32_libdir}/libpangowin32-1.0.dll.a
86 %{_mingw32_libdir}/libpangowin32-1.0.la
87 %{_mingw32_libdir}/pango-1.0.def
88 %{_mingw32_libdir}/pangocairo-1.0.def
89 %{_mingw32_libdir}/pangoft2-1.0.def
90 %{_mingw32_libdir}/pangowin32-1.0.def
91 %{_mingw32_libdir}/pango/
92 %{_mingw32_libdir}/pkgconfig/pango.pc
93 %{_mingw32_libdir}/pkgconfig/pangocairo.pc
94 %{_mingw32_libdir}/pkgconfig/pangoft2.pc
95 %{_mingw32_libdir}/pkgconfig/pangowin32.pc
96 %{_mingw32_datadir}/gtk-doc/html/pango/
97 %{_mingw32_mandir}/man1/pango-querymodules.1*
98 %{_mingw32_sysconfdir}/pango/
99
100
101 %changelog
102 * Tue Jan 27 2009 Levente Farkas <lfarkas@lfarkas.org> - 1.22.1-3
103 - Include license file in documentation section.
104
105 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-2
106 - Disable static libraries.
107 - Use _smp_mflags.
108
109 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-1
110 - New upstream version 1.22.1.
111 - BR cairo >= 1.8.0 because of important fixes.
112
113 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-6
114 - Rename mingw -> mingw32.
115
116 * Tue Sep 23 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-5
117 - Remove use of wine in %-post.
118
119 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-4
120 - Add dep on pkgconfig
121
122 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-3
123 - post/preun scripts to update the pango.modules list.
124
125 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-2
126 - Run the correct glib-mkenums.
127
128 * Tue Sep  9 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-1
129 - Initial RPM release