1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
10 Summary: MinGW Windows Pango library
13 Group: Development/Libraries
14 URL: http://www.pango.org
15 Source0: http://download.gnome.org/sources/pango/1.21/pango-%{version}.tar.bz2
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19 # Native pango uses a %post script to generate this, but the
20 # pango-querymodules.exe binary is not something we can easily run on
21 # a Linux host. We could use wine but wine isn't happy in a mock
22 # environment. So we just include a pre-generated copy on basis that
23 # it won't ever change much.
25 # If you want to rebuild this, do:
26 # wine %{_mingw32_bindir}/pango-querymodules.exe > pango.modules
27 Source1: pango.modules
31 BuildRequires: mingw32-filesystem >= 23
32 BuildRequires: mingw32-gcc
33 BuildRequires: mingw32-binutils
34 BuildRequires: mingw32-iconv
35 BuildRequires: mingw32-gettext
36 BuildRequires: mingw32-cairo >= 1.8.0
37 BuildRequires: mingw32-freetype
38 BuildRequires: mingw32-fontconfig
39 BuildRequires: mingw32-glib2
40 BuildRequires: pkgconfig
43 MinGW Windows Pango library.
47 %setup -q -n pango-%{version}
50 # Need to run the correct version of glib-mkenums.
51 PATH=%{_mingw32_bindir}:$PATH \
52 %{_mingw32_configure} --disable-static
57 rm -rf $RPM_BUILD_ROOT
59 make DESTDIR=$RPM_BUILD_ROOT install
61 mkdir -p $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
62 cp %{SOURCE1} $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
64 rm -f $RPM_BUILD_ROOT/%{_mingw32_libdir}/charset.alias
68 rm -rf $RPM_BUILD_ROOT
72 %{_mingw32_bindir}/libpango-1.0-0.dll
73 %{_mingw32_bindir}/libpangocairo-1.0-0.dll
74 %{_mingw32_bindir}/libpangoft2-1.0-0.dll
75 %{_mingw32_bindir}/libpangowin32-1.0-0.dll
76 %{_mingw32_bindir}/pango-querymodules.exe
77 %{_mingw32_includedir}/pango-1.0/
78 %{_mingw32_libdir}/libpango-1.0.dll.a
79 %{_mingw32_libdir}/libpango-1.0.la
80 %{_mingw32_libdir}/libpangocairo-1.0.dll.a
81 %{_mingw32_libdir}/libpangocairo-1.0.la
82 %{_mingw32_libdir}/libpangoft2-1.0.dll.a
83 %{_mingw32_libdir}/libpangoft2-1.0.la
84 %{_mingw32_libdir}/libpangowin32-1.0.dll.a
85 %{_mingw32_libdir}/libpangowin32-1.0.la
86 %{_mingw32_libdir}/pango-1.0.def
87 %{_mingw32_libdir}/pangocairo-1.0.def
88 %{_mingw32_libdir}/pangoft2-1.0.def
89 %{_mingw32_libdir}/pangowin32-1.0.def
90 %{_mingw32_libdir}/pango/
91 %{_mingw32_libdir}/pkgconfig/pango.pc
92 %{_mingw32_libdir}/pkgconfig/pangocairo.pc
93 %{_mingw32_libdir}/pkgconfig/pangoft2.pc
94 %{_mingw32_libdir}/pkgconfig/pangowin32.pc
95 %{_mingw32_datadir}/gtk-doc/html/pango/
96 %{_mingw32_mandir}/man1/pango-querymodules.1*
97 %{_mingw32_sysconfdir}/pango/
101 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-2
102 - Disable static libraries.
105 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-1
106 - New upstream version 1.22.1.
107 - BR cairo >= 1.8.0 because of important fixes.
109 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-6
110 - Rename mingw -> mingw32.
112 * Tue Sep 23 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-5
113 - Remove use of wine in %-post.
115 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-4
116 - Add dep on pkgconfig
118 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-3
119 - post/preun scripts to update the pango.modules list.
121 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-2
122 - Run the correct glib-mkenums.
124 * Tue Sep 9 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-1
125 - Initial RPM release