Add post/preun scripts to update various module lists.
[fedora-mingw.git] / pango / mingw-pango.spec
1 %define __strip %{_mingw_strip}
2 %define __objdump %{_mingw_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw_findrequires}
5 %define __find_provides %{_mingw_findprovides}
6
7 Name:           mingw-pango
8 Version:        1.21.6
9 Release:        3%{?dist}
10 Summary:        MinGW Windows Pango library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.pango.org
15 Source0:        http://download.gnome.org/sources/pango/1.21/pango-%{version}.tar.bz2
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw-filesystem >= 23
21 BuildRequires:  mingw-gcc
22 BuildRequires:  mingw-binutils
23 BuildRequires:  mingw-iconv
24 BuildRequires:  mingw-gettext
25 BuildRequires:  mingw-cairo
26 BuildRequires:  mingw-freetype
27 BuildRequires:  mingw-fontconfig
28
29 Requires(post): wine
30
31
32 %description
33 MinGW Windows Pango library.
34
35
36 %prep
37 %setup -q -n pango-%{version}
38
39 %build
40 # Need to run the correct version of glib-mkenums.
41 PATH=%{_mingw_bindir}:$PATH
42
43 %{_mingw_configure}
44 make
45
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 make DESTDIR=$RPM_BUILD_ROOT install
51
52 mkdir -p $RPM_BUILD_ROOT%{_mingw_sysconfdir}/pango/
53
54 rm -f $RPM_BUILD_ROOT/%{_mingw_libdir}/charset.alias
55
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60
61 %post
62 wine %{_mingw_bindir}/pango-querymodules.exe \
63   > %{_mingw_sysconfdir}/pango/pango.modules
64
65 %preun
66 rm -f %{_mingw_sysconfdir}/pango/pango.modules
67
68
69 %files
70 %defattr(-,root,root)
71 %{_mingw_bindir}/libpango-1.0-0.dll
72 %{_mingw_bindir}/libpangocairo-1.0-0.dll
73 %{_mingw_bindir}/libpangoft2-1.0-0.dll
74 %{_mingw_bindir}/libpangowin32-1.0-0.dll
75 %{_mingw_bindir}/pango-querymodules.exe
76 %{_mingw_includedir}/pango-1.0/
77 %{_mingw_libdir}/libpango-1.0.dll.a
78 %{_mingw_libdir}/libpango-1.0.la
79 %{_mingw_libdir}/libpangocairo-1.0.dll.a
80 %{_mingw_libdir}/libpangocairo-1.0.la
81 %{_mingw_libdir}/libpangoft2-1.0.dll.a
82 %{_mingw_libdir}/libpangoft2-1.0.la
83 %{_mingw_libdir}/libpangowin32-1.0.dll.a
84 %{_mingw_libdir}/libpangowin32-1.0.la
85 %{_mingw_libdir}/pango-1.0.def
86 %{_mingw_libdir}/pangocairo-1.0.def
87 %{_mingw_libdir}/pangoft2-1.0.def
88 %{_mingw_libdir}/pangowin32-1.0.def
89 %{_mingw_libdir}/pango/
90 %{_mingw_libdir}/pkgconfig/pango.pc
91 %{_mingw_libdir}/pkgconfig/pangocairo.pc
92 %{_mingw_libdir}/pkgconfig/pangoft2.pc
93 %{_mingw_libdir}/pkgconfig/pangowin32.pc
94 %{_mingw_datadir}/gtk-doc/html/pango/
95 %{_mingw_mandir}/man1/pango-querymodules.1*
96 %{_mingw_sysconfdir}/pango/
97
98
99 %changelog
100 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-3
101 - post/preun scripts to update the pango.modules list.
102
103 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-2
104 - Run the correct glib-mkenums.
105
106 * Tue Sep  9 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-1
107 - Initial RPM release