Added ocaml XML Light
[fedora-mingw.git] / ocaml-xml-light / mingw32-ocaml-xml-light.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-ocaml-xml-light
8 Version:        2.2.cvs20070817
9 Release:        1%{?dist}
10 Summary:        MinGW Windows minimal XML parser and printer for OCaml
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14
15 URL:            http://tech.motion-twin.com/xmllight.html
16 Source0:        xml-light-%{version}.tar.gz
17
18 # Patches for MinGW:
19 Patch1000:      mingw32-ocaml-xml-light-2.2-build.patch
20
21 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22 BuildArch:      noarch
23
24 BuildRequires:  mingw32-filesystem >= 35
25 BuildRequires:  mingw32-gcc
26 BuildRequires:  mingw32-binutils
27 BuildRequires:  mingw32-ocaml
28
29
30 %description
31 Xml-Light is a minimal XML parser & printer for OCaml. It provides
32 functions to parse an XML document into an OCaml data structure, work
33 with it, and print it back to an XML document. It support also DTD
34 parsing and checking, and is entirely written in OCaml, hence it does
35 not require additional C library.
36
37
38 %prep
39 %setup -q -c -n %{name}-%{version}
40
41 %patch1000 -p0
42
43
44 %build
45 make opt
46 sed -e 's/@VERSION@/%{VERSION}/' < META.in > META
47
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/xml-light
53
54 install xml-light.cmxa xml-light.a *.mli *.cmi *.cmx \
55   $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/xml-light
56 install META $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/xml-light
57
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62
63 %files
64 %defattr(-,root,root)
65 %{_libdir}/%{_mingw32_target}-ocaml/xml-light/
66
67
68 %changelog
69 * Sat Nov 15 2008 Richard W.M. Jones <rjones@redhat.com> - 2.2cvs20070817-1
70 - Initial RPM release.