1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
7 %define debug_package %{nil}
9 %define otherlibraries win32unix str num dynlink bigarray systhreads win32graph
14 Summary: Objective Caml MinGW cross-compiler and programming environment
16 License: QPL and (LGPLv2+ with exceptions)
17 Group: Development/Libraries
19 URL: http://caml.inria.fr/
20 Source0: http://caml.inria.fr/pub/distrib/ocaml-3.11/ocaml-%{version}.tar.bz2
22 # This is installed as config/Makefile when we cross-compile.
23 Source1000: Makefile-fedora-mingw.in
25 # XXX We should apply any Fedora native patches here.
27 # For patch description, see the top of each patch file.
28 # Start numbering at 1000 since these are MinGW-specific patches.
29 Patch1000: mingw32-ocaml-3.11.0+beta1-combined-Makefile.patch
30 Patch1001: mingw32-ocaml-3.11.0+beta1-disable-cmxs.patch
31 Patch1002: mingw32-ocaml-3.11.0+beta1-filename-win32-dirsep.patch
32 Patch1003: mingw32-ocaml-3.11.0+beta1-i386-profiling.patch
33 Patch1004: mingw32-ocaml-3.11.0+beta1-no-stdlib-dir.patch
34 Patch1005: mingw32-ocaml-3.11.0+beta1-win32-fixes.patch
35 Patch1006: mingw32-ocaml-3.11.0+beta1-win32unix-path.patch
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
41 BuildRequires: mingw32-filesystem >= 30
42 BuildRequires: mingw32-gcc
43 BuildRequires: mingw32-binutils
44 BuildRequires: mingw32-flexdll
46 # While we still ship bytecode, this requires a /usr/bin/ocamlrun from
47 # the _identical_ native package. We don't have that at the moment,
48 # which is why this is commented out.
49 #Requires: ocaml-runtime = %{version}
53 Objective Caml is a high-level, strongly-typed, functional and
54 object-oriented programming language from the ML family of languages.
56 This package is an OCaml cross-compiler which runs natively on Fedora
57 and produces Windows native executables.
61 %setup -q -n ocaml-%{version}
73 # Build native ocamlrun and ocamlc which contain the filename-win32-dirsep
78 -libdir %{_libdir}/ocaml \
79 -mandir %{_mandir}/man1
82 # Now move the working ocamlrun, ocamlc into the boot/ directory,
83 # overwriting the binary versions which ship with the compiler with
84 # ones that contain the above filename-win32-dirsep patch.
87 # Now replace the compiler configuration (config/{s.h,m.h,Makefile})
88 # with ones as they would be on a 32 bit Windows system.
91 # config/m.h can just be copied from config/m-nt.h which ships.
95 # config/s.h can just be copied from config/s-nt.h which ships.
99 # config/Makefile is a custom one which we supply.
102 -e 's,@prefix@,%{_prefix},g' \
103 -e 's,@bindir@,%{_bindir},g' \
104 -e 's,@libdir@,%{_libdir},g' \
105 -e 's,@target@,%{_mingw32_target},g' \
106 -e 's,@otherlibraries@,%{otherlibraries},g' \
107 < %{SOURCE1000} > Makefile
111 # We're going to build in otherlibs/win32unix and otherlibs/win32graph
112 # directories, but since they would normally only be built under
113 # Windows, they only have the Makefile.nt files. Just symlink
114 # Makefile -> Makefile.nt for these cases.
115 for d in otherlibs/win32unix otherlibs/win32graph; do
116 ln -s Makefile.nt $d/Makefile
119 # Now clean the temporary files from the previous build. This
120 # will also cause asmcomp/arch.ml (etc) to be linked to the 32 bit
121 # i386 versions, essentially causing ocamlopt to use the Win/i386 code
125 # Just rebuild some small bits that we need for the following
126 # 'make opt' to work. Note that 'make all' fails here.
127 make -C byterun libcamlrun.a
130 make -C tools ocamlmklib
137 rm -rf $RPM_BUILD_ROOT
139 mkdir -p $RPM_BUILD_ROOT%{_bindir}
140 mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml
141 mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/threads
142 mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/stublibs
144 # This is the equivalent of 'make install installopt', but
145 # we only want to install the parts which are really necessary
146 # for the cross-compiler. eg. We don't need any of the native
147 # tools like ocamllex or ocamldoc.
148 %define makevars BINDIR=$RPM_BUILD_ROOT%{_bindir} LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml
149 make %{makevars} -C byterun install
150 make %{makevars} -C stdlib install
151 for i in %{otherlibraries}; do
152 make %{makevars} -C otherlibs/$i install
154 make %{makevars} installopt
157 $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/Makefile.config
159 # Rename the binaries so they don't clash with base OCaml package.
160 mv $RPM_BUILD_ROOT%{_bindir}/ocamlrun \
161 $RPM_BUILD_ROOT%{_bindir}/%{_mingw32_target}-ocamlrun
162 echo '#!%{_bindir}/%{_mingw32_target}-ocamlrun' \
163 > $RPM_BUILD_ROOT%{_bindir}/%{_mingw32_target}-ocamlopt
164 tail -n +2 $RPM_BUILD_ROOT%{_bindir}/ocamlopt \
165 >> $RPM_BUILD_ROOT%{_bindir}/%{_mingw32_target}-ocamlopt
166 chmod 0755 $RPM_BUILD_ROOT%{_bindir}/%{_mingw32_target}-ocamlopt
167 rm $RPM_BUILD_ROOT%{_bindir}/ocamlopt
171 rm -rf $RPM_BUILD_ROOT
175 %defattr(-,root,root)
176 %{_bindir}/%{_mingw32_target}-ocamlrun
177 %{_bindir}/%{_mingw32_target}-ocamlopt
178 %{_libdir}/%{_mingw32_target}-ocaml/
182 * Sat Nov 15 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11.0+beta1-4
183 - Initial RPM release.