Added libxslt.
[fedora-mingw.git] / libxslt / mingw32-libxslt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libxslt
8 Version:        1.1.24
9 Release:        1%{?dist}
10 Summary:        MinGW Windows Library providing the Gnome XSLT engine
11
12 License:        MIT
13 Group:          Development/Libraries
14 URL:            http://xmlsoft.org/XSLT/
15 Source0:        ftp://xmlsoft.org/XSLT/libxslt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 Patch0:         multilib.patch
21 Patch1:         libexslt-rc4.patch
22
23 Patch1000:      mingw32-libxslt-1.1.24-win32-shared.patch
24
25 BuildRequires:  mingw32-filesystem >= 30
26 BuildRequires:  mingw32-gcc
27 BuildRequires:  mingw32-binutils
28 BuildRequires:  mingw32-libxml2 >= 2.7.2-3
29
30 Requires:       mingw32-libxml2 >= 2.7.2-3
31
32
33 %description
34 This C library allows to transform XML files into other XML files
35 (or HTML, text, ...) using the standard XSLT stylesheet transformation
36 mechanism. To use it you need to have a version of libxml2 >= 2.6.27
37 installed. The xsltproc command is a command line interface to the XSLT engine
38
39
40 %prep
41 %setup -q -n libxslt-%{version}
42 %patch0 -p1
43 %patch1 -p0
44
45 %patch1000 -p1
46
47
48 %build
49 %{_mingw32_configure} --without-python --enable-shared
50 make
51 gzip -9 ChangeLog
52
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 make DESTDIR=$RPM_BUILD_ROOT install
57
58 # Remove static libraries but DON'T remove *.dll.a files.
59 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libexslt.a
60 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libxslt.a
61
62 # Remove doc and man which duplicate stuff already in Fedora native package.
63 rm -r $RPM_BUILD_ROOT%{_mingw32_docdir}
64 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}
65
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70
71 %files
72 %defattr(-,root,root)
73 %{_mingw32_bindir}/xslt-config
74 %{_mingw32_bindir}/xsltproc.exe
75 %{_mingw32_includedir}/libexslt
76 %{_mingw32_includedir}/libxslt
77 #%{_mingw32_bindir}/libexslt.dll
78 #%{_mingw32_libdir}/libexslt.dll.a
79 %{_mingw32_libdir}/libexslt.la
80 %{_mingw32_bindir}/libxslt-1.dll
81 %{_mingw32_libdir}/libxslt.dll.a
82 %{_mingw32_libdir}/libxslt.la
83 %{_mingw32_libdir}/pkgconfig/libexslt.pc
84 %{_mingw32_libdir}/pkgconfig/libxslt.pc
85 %{_mingw32_libdir}/xsltConf.sh
86 %{_mingw32_datadir}/aclocal/libxslt.m4
87
88
89 %changelog
90 * Sat Oct 25 2008 Richard W.M. Jones <rjones@redhat.com> - 1.1.24-1
91 - Initial RPM release.