- Use _smp_mflags.
[fedora-mingw.git] / libxml2 / mingw32-libxml2.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libxml2
8 Version:        2.7.2
9 Release:        5%{?dist}
10 Summary:        MinGW Windows libxml2 XML processing library
11
12 License:        MIT
13 Group:          Development/Libraries
14 URL:            http://xmlsoft.org/
15 Source0:        ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 # Not required for MinGW.
19 #Patch0:         libxml2-multilib.patch
20
21 # MinGW-specific patches.
22 Patch1000:      mingw32-libxml2-2.7.2-with-modules.patch
23
24 BuildArch:      noarch
25
26 BuildRequires:  mingw32-filesystem >= 23
27 BuildRequires:  mingw32-gcc
28 BuildRequires:  mingw32-binutils
29 BuildRequires:  mingw32-zlib
30 BuildRequires:  mingw32-gettext
31
32 Requires:       pkgconfig
33
34
35 %description
36 MinGW Windows libxml2 XML processing library.
37
38
39 %prep
40 %setup -q -n libxml2-%{version}
41 %patch1000 -p1
42
43
44 %build
45 LDFLAGS="-no-undefined" \
46 %{_mingw32_configure} --without-python --with-modules --disable-static
47 make %{?_smp_mflags}
48
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 make DESTDIR=$RPM_BUILD_ROOT install
54
55 # Remove manpages which duplicate Fedora native.
56 rm -rf $RPM_BUILD_ROOT%{_mingw32_mandir}
57
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62
63 %files
64 %defattr(-,root,root)
65 %{_mingw32_bindir}/libxml2-2.dll
66 %{_mingw32_bindir}/xml2-config
67 %{_mingw32_bindir}/xmlcatalog.exe
68 %{_mingw32_bindir}/xmllint.exe
69 %{_mingw32_libdir}/libxml2.dll.a
70 %{_mingw32_libdir}/libxml2.la
71 %{_mingw32_libdir}/pkgconfig
72 %{_mingw32_libdir}/pkgconfig/libxml-2.0.pc
73 %{_mingw32_libdir}/xml2Conf.sh
74 %{_mingw32_includedir}/libxml2
75 %{_mingw32_datadir}/aclocal/*
76 %{_mingw32_docdir}/libxml2-%{version}/
77 %{_mingw32_datadir}/gtk-doc/html/libxml2/
78
79
80 %changelog
81 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-5
82 - Use _smp_mflags.
83 - Disable static libraries.
84
85 * Tue Jan 13 2009 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-4
86 - Requires pkgconfig.
87
88 * Sat Oct 25 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-3
89 - Enable modules support for libxslt.
90
91 * Fri Oct 17 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-1
92 - Resynch to native Fedora package + patch.
93
94 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.1-2
95 - Rename mingw -> mingw32.
96
97 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 2.7.1-1
98 - Update to 2.7.1 release
99
100 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-5
101 - Remove manpages which duplicate Fedora native.
102
103 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-4
104 - Remove static libraries.
105 - List libdir files explicitly.
106
107 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-3
108 - Use RPM macros from mingw-filesystem.
109 - BuildArch is noarch.
110
111 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-1
112 - Initial RPM release, largely based on earlier work from several sources.