Introduce a mingw-filesystem package which contains the basic fs layout.
[fedora-mingw.git] / libxml2 / mingw-libxml2.spec
1 %define __os_install_post /usr/lib/rpm/brp-compress %{nil}
2
3 Name:           mingw-libxml2
4 Version:        2.6.32
5 Release:        1%{?dist}
6 Summary:        MinGW Windows libxml2 XML processing library
7
8 License:        LGPLv2+
9 Group:          Development/Libraries
10 URL:            http://www.xmlsoft.org/
11 Source0:        ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 BuildRequires:  mingw-gcc
15 BuildRequires:  mingw-binutils
16 BuildRequires:  mingw-zlib
17
18 Requires:       mingw-runtime
19
20 %description
21 MinGW Windows libxml2 XML processing library.
22
23
24 %prep
25 %setup -q -n libxml2-%{version}
26
27
28 %build
29 CFLAGS="-O2 -g -Wall -pipe" LDFLAGS="-no-undefined" \
30 ./configure \
31   --build=%_build \
32   --host=i686-pc-mingw32 \
33   --prefix=%{_prefix}/i686-pc-mingw32/sys-root/mingw \
34   --without-python
35
36 make
37
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 make DESTDIR=$RPM_BUILD_ROOT install
43
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48
49 %files
50 %defattr(-,root,root)
51 %{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/*
52 %{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/*
53 %{_prefix}/i686-pc-mingw32/sys-root/mingw/include/*
54 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/aclocal/*
55 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/doc/libxml2-%{version}/
56 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/gtk-doc/html/libxml2/
57 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man/man1/*
58 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man/man3/*
59
60
61 %changelog
62 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-1
63 - Initial RPM release, largely based on earlier work from several sources.