New version 0.5.0.
[fedora-mingw.git] / libvirt / mingw32-libvirt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libvirt
8 Version:        0.5.0
9 Release:        9%{?dist}%{?extra_release}
10 Summary:        MinGW Windows libvirt virtualization library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libvirt.org/
15 Source0:        ftp://libvirt.org/libvirt/libvirt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildRequires:  mingw32-filesystem >= 23
19 BuildRequires:  mingw32-gcc
20 BuildRequires:  mingw32-binutils
21 BuildRequires:  mingw32-libgpg-error
22 BuildRequires:  mingw32-libgcrypt
23 BuildRequires:  mingw32-gnutls
24 BuildRequires:  mingw32-gettext
25 BuildRequires:  mingw32-libxml2
26 # Portable XDR <= 4.0.10 contains a serious endianness bug on Windows.
27 BuildRequires:  mingw32-portablexdr >= 4.0.11
28 BuildRequires:  mingw32-readline
29 BuildRequires:  mingw32-termcap >= 1.3.1-3
30 BuildRequires:  pkgconfig
31
32 # Need native version for msgfmt
33 BuildRequires:  gettext
34
35 BuildArch:      noarch
36
37
38 %description
39 MinGW Windows libvirt virtualization library.
40
41
42 %prep
43 %setup -q -n libvirt-%{version}
44
45
46 %build
47 # XXX enable SASL in future
48 %{_mingw32_configure} \
49   --without-sasl \
50   --without-avahi \
51   --without-polkit \
52   --without-python \
53   --without-xen \
54   --without-qemu \
55   --without-lxc \
56   --without-openvz \
57   --without-uml \
58   --without-libvirtd
59 make
60
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 make DESTDIR=$RPM_BUILD_ROOT install
66
67 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/libvirt
68 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
69 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc/*
70
71 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libvirt.a
72
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77
78 %files
79 %defattr(-,root,root)
80 %{_mingw32_bindir}/libvirt-0.dll
81 %{_mingw32_bindir}/virsh.exe
82
83 %{_mingw32_libdir}/libvirt.dll.a
84 %{_mingw32_libdir}/libvirt.la
85 %{_mingw32_libdir}/pkgconfig/libvirt.pc
86
87 %{_mingw32_datadir}/locale/*/LC_MESSAGES/libvirt.mo
88
89 %dir %{_mingw32_includedir}/libvirt
90 %{_mingw32_includedir}/libvirt/libvirt.h
91 %{_mingw32_includedir}/libvirt/virterror.h
92
93 %{_mingw32_mandir}/man1/virsh.1*
94
95
96 %changelog
97 * Wed Nov 26 2008 Richard Jones <rjones@redhat.com> - 0.5.0-1
98 - New upstream version 0.5.0.
99
100 * Sat Nov 22 2008 Richard Jones <rjones@redhat.com> - 0.4.6-9
101 - Rebuild against new readline.
102
103 * Fri Oct 31 2008 Richard Jones <rjones@redhat.com> - 0.4.6-8
104 - Rebuild against latest termcap.
105
106 * Thu Oct 16 2008 Richard Jones <rjones@redhat.com> - 0.4.6-7
107 - Windows icon patch from
108   https://www.redhat.com/archives/libvir-list/2008-October/msg00331.html
109
110 * Wed Oct 15 2008 Richard Jones <rjones@redhat.com> - 0.4.6-6
111 - Add patches from
112   https://www.redhat.com/archives/libvir-list/2008-October/msg00328.html
113 - BR mingw32-portablexdr >= 4.0.11 to fix serious Windows endianness bug.
114
115 * Tue Oct 14 2008 Richard Jones <rjones@redhat.com> - 0.4.6-4
116 - +BR mingw32-readline.
117
118 * Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 0.4.6-3
119 - BuildArch should be noarch
120
121 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-2
122 - Whitespace removal.
123
124 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-1
125 - New upstream release 0.4.6.
126 - Rename mingw -> mingw32.
127
128 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-4%{?extra_release}
129 - Import crash fix from rawhide
130
131 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-3%{?extra_release}
132 - Add dep on gettext & pkgconfig
133
134 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-2
135 - Remove static lib.
136
137 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.4-1
138 - Initial RPM release, largely based on earlier work from several sources.