New upstream release of libxml2.
[fedora-mingw.git] / libvirt / mingw32-libvirt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libvirt
8 Version:        0.4.6
9 Release:        7%{?dist}%{?extra_release}
10 Summary:        MinGW Windows libvirt virtualization library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libvirt.org/
15 Source0:        ftp://libvirt.org/libvirt/libvirt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 # All of these patches are upstream after 0.4.6.
19 Patch0:         mingw32-libvirt-0.4.6-debug-registration.patch
20 Patch1:         mingw32-libvirt-0.4.6-register-remote.patch
21 Patch2:         mingw32-libvirt-0.4.6-win-icon.patch
22 Source1:        libvirt_win_icon_16x16.ico
23 Source2:        libvirt_win_icon_32x32.ico
24 Source3:        libvirt_win_icon_48x48.ico
25 Source4:        libvirt_win_icon_64x64.ico
26
27 BuildRequires:  mingw32-filesystem >= 23
28 BuildRequires:  mingw32-gcc
29 BuildRequires:  mingw32-binutils
30 BuildRequires:  mingw32-libgpg-error
31 BuildRequires:  mingw32-libgcrypt
32 BuildRequires:  mingw32-gnutls
33 BuildRequires:  mingw32-gettext
34 BuildRequires:  mingw32-libxml2
35 # Portable XDR <= 4.0.10 contains a serious endianness bug on Windows.
36 BuildRequires:  mingw32-portablexdr >= 4.0.11
37 BuildRequires:  mingw32-readline
38 BuildRequires:  pkgconfig
39
40 # Need native version for msgfmt
41 BuildRequires:  gettext
42
43 # For autoreconf.
44 BuildRequires:  autoconf, automake, libtool
45
46 BuildArch:      noarch
47
48
49 %description
50 MinGW Windows libvirt virtualization library.
51
52
53 %prep
54 %setup -q -n libvirt-%{version}
55 %patch0 -p1
56 %patch1 -p1
57 %patch2 -p0
58 cp %{SOURCE1} src/
59 cp %{SOURCE2} src/
60 cp %{SOURCE3} src/
61 cp %{SOURCE4} src/
62 autoreconf
63
64
65 %build
66 # XXX enable SASL in future
67 %{_mingw32_configure} \
68   --without-sasl \
69   --without-avahi \
70   --without-polkit \
71   --without-python \
72   --without-xen \
73   --without-qemu \
74   --without-lxc \
75   --without-openvz \
76   --without-libvirtd
77 make
78
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 make DESTDIR=$RPM_BUILD_ROOT install
84
85 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/libvirt
86 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
87 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc/*
88
89 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libvirt.a
90
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95
96 %files
97 %defattr(-,root,root)
98 %{_mingw32_bindir}/libvirt-0.dll
99 %{_mingw32_bindir}/virsh.exe
100
101 %{_mingw32_libdir}/libvirt.dll.a
102 %{_mingw32_libdir}/libvirt.la
103 %{_mingw32_libdir}/pkgconfig/libvirt.pc
104
105 %{_mingw32_datadir}/locale/*/LC_MESSAGES/libvirt.mo
106
107 %dir %{_mingw32_includedir}/libvirt
108 %{_mingw32_includedir}/libvirt/libvirt.h
109 %{_mingw32_includedir}/libvirt/virterror.h
110
111 %{_mingw32_mandir}/man1/virsh.1*
112
113
114 %changelog
115 * Thu Oct 16 2008 Richard Jones <rjones@redhat.com> - 0.4.6-7
116 - Windows icon patch from
117   https://www.redhat.com/archives/libvir-list/2008-October/msg00331.html
118
119 * Wed Oct 15 2008 Richard Jones <rjones@redhat.com> - 0.4.6-6
120 - Add patches from
121   https://www.redhat.com/archives/libvir-list/2008-October/msg00328.html
122 - BR mingw32-portablexdr >= 4.0.11 to fix serious Windows endianness bug.
123
124 * Tue Oct 14 2008 Richard Jones <rjones@redhat.com> - 0.4.6-4
125 - +BR mingw32-readline.
126
127 * Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 0.4.6-3
128 - BuildArch should be noarch
129
130 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-2
131 - Whitespace removal.
132
133 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-1
134 - New upstream release 0.4.6.
135 - Rename mingw -> mingw32.
136
137 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-4%{?extra_release}
138 - Import crash fix from rawhide
139
140 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-3%{?extra_release}
141 - Add dep on gettext & pkgconfig
142
143 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-2
144 - Remove static lib.
145
146 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.4-1
147 - Initial RPM release, largely based on earlier work from several sources.