Libvirt requires readline.
[fedora-mingw.git] / libvirt / mingw32-libvirt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libvirt
8 Version:        0.4.6
9 Release:        4%{?dist}%{?extra_release}
10 Summary:        MinGW Windows libvirt virtualization library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libvirt.org/
15 Source0:        ftp://libvirt.org/libvirt/libvirt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildRequires:  mingw32-filesystem >= 23
19 BuildRequires:  mingw32-gcc
20 BuildRequires:  mingw32-binutils
21 BuildRequires:  mingw32-libgpg-error
22 BuildRequires:  mingw32-libgcrypt
23 BuildRequires:  mingw32-gnutls
24 BuildRequires:  mingw32-gettext
25 BuildRequires:  mingw32-libxml2
26 BuildRequires:  mingw32-portablexdr
27 BuildRequires:  mingw32-readline
28 BuildRequires:  pkgconfig
29 # Need native version for msgfmt
30 BuildRequires:  gettext
31
32 BuildArch:      noarch
33
34
35 %description
36 MinGW Windows libvirt virtualization library.
37
38
39 %prep
40 %setup -q -n libvirt-%{version}
41
42
43 %build
44 # XXX enable SASL in future
45 %{_mingw32_configure} \
46   --without-sasl \
47   --without-avahi \
48   --without-polkit \
49   --without-python \
50   --without-xen \
51   --without-qemu \
52   --without-lxc \
53   --without-openvz \
54   --without-libvirtd
55 make
56
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 make DESTDIR=$RPM_BUILD_ROOT install
62
63 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/libvirt
64 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
65 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc/*
66
67 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libvirt.a
68
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73
74 %files
75 %defattr(-,root,root)
76 %{_mingw32_bindir}/libvirt-0.dll
77 %{_mingw32_bindir}/virsh.exe
78
79 %{_mingw32_libdir}/libvirt.dll.a
80 %{_mingw32_libdir}/libvirt.la
81 %{_mingw32_libdir}/pkgconfig/libvirt.pc
82
83 %{_mingw32_datadir}/locale/*/LC_MESSAGES/libvirt.mo
84
85 %dir %{_mingw32_includedir}/libvirt
86 %{_mingw32_includedir}/libvirt/libvirt.h
87 %{_mingw32_includedir}/libvirt/virterror.h
88
89 %{_mingw32_mandir}/man1/virsh.1*
90
91
92 %changelog
93 * Tue Oct 14 2008 Richard Jones <rjones@redhat.com> - 0.4.6-4
94 - +BR mingw32-readline.
95
96 * Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 0.4.6-3
97 - BuildArch should be noarch
98
99 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-2
100 - Whitespace removal.
101
102 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-1
103 - New upstream release 0.4.6.
104 - Rename mingw -> mingw32.
105
106 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-4%{?extra_release}
107 - Import crash fix from rawhide
108
109 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-3%{?extra_release}
110 - Add dep on gettext & pkgconfig
111
112 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-2
113 - Remove static lib.
114
115 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.4-1
116 - Initial RPM release, largely based on earlier work from several sources.