- Rebase to native Fedora version 1.14.11.
[fedora-mingw.git] / libgsf / mingw32-libgsf.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libgsf
8 Version:        1.14.11
9 Release:        1%{?dist}
10 Summary:        MinGW Windows port of GNOME Structured File Library
11
12 License:        LGPLv2
13 Group:          Development/Libraries
14
15 URL:            http://www.gnome.org/projects/libgsf/
16 Source0:        ftp://ftp.gnome.org/pub/GNOME/sources/libgsf/1.14/libgsf-%{version}.tar.bz2
17
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19 BuildArch:      noarch
20
21 BuildRequires:  mingw32-filesystem >= 35
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-binutils
24 BuildRequires:  mingw32-glib2
25 BuildRequires:  mingw32-libxml2
26 BuildRequires:  mingw32-bzip2 >= 1.0.5-4
27 BuildRequires:  mingw32-gettext
28 BuildRequires:  mingw32-iconv
29 BuildRequires:  mingw32-zlib
30 # We don't have bonobo in MinGW yet:
31 #BuildRequires:  mingw32-libbonobo
32 # We don't build Python packages yet:
33 #BuildRequires:  mingw32-pygtk2
34 # Seems like this is only needed for GNOME integration:
35 #BuildRequires:  mingw32-gnome-vfs2
36
37 BuildRequires:  autoconf
38 BuildRequires:  pkgconfig
39 BuildRequires:  intltool
40
41 Patch1000:      mingw32-libgsf-1.14.10-better-bz2-detection.patch
42 Patch1001:      mingw32-libgsf-1.14.10-glib-deprecated.patch
43
44
45 %description
46 A library for reading and writing structured files (eg MS OLE and Zip).
47
48 This is the MinGW Windows cross-compiled port of libgsf.
49
50
51 %prep
52 %setup -q -n libgsf-%{version}
53
54 %patch1000 -p1
55 %patch1001 -p1
56
57 autoconf
58
59
60 %build
61 %{_mingw32_configure} \
62   --disable-gtk-doc --disable-static \
63   --without-gnome-vfs --without-bonobo
64 make %{?_smp_mflags}
65
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
71 make DESTDIR=$RPM_BUILD_ROOT install
72
73 # Remove documentation which duplicates the Fedora native package.
74 rm -r $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc
75 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}/man1
76
77 # If native gconftool was installed then we will build the
78 # schemas.  However those are not useful under Windows because
79 # we don't have gconf itself.  Thus remove them if they were
80 # built.
81 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/gconf
82 # Also gsf-office-thumbnailer only gets built if gconftool
83 # is installed.
84 rm -f $RPM_BUILD_ROOT%{_mingw32_bindir}/gsf-office-thumbnailer.exe
85
86 %find_lang libgsf
87
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92
93 %files -f libgsf.mo
94 %defattr(-,root,root)
95 %{_mingw32_bindir}/gsf.exe
96 %{_mingw32_bindir}/gsf-vba-dump.exe
97 %{_mingw32_bindir}/libgsf-1-114.dll
98 %{_mingw32_bindir}/libgsf-win32-1-114.dll
99 %{_mingw32_libdir}/libgsf-1.dll.a
100 %{_mingw32_libdir}/libgsf-1.la
101 %{_mingw32_libdir}/libgsf-win32-1.dll.a
102 %{_mingw32_libdir}/libgsf-win32-1.la
103 %{_mingw32_libdir}/pkgconfig/libgsf-1.pc
104 %{_mingw32_libdir}/pkgconfig/libgsf-win32-1.pc
105 %{_mingw32_includedir}/libgsf-1/
106
107
108 %changelog
109 * Fri Jan 23 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.11-1
110 - Rebase to native Fedora version 1.14.11.
111 - Use find_lang macro.
112
113 * Sat Nov 22 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.10-2
114 - +BR intltool.
115
116 * Sat Nov 22 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.10-1
117 - Initial RPM release.