Replace %include of defs with explicit macros to avoid chicken+egg problem in mock...
[fedora-mingw.git] / libgpg-error / mingw-libgpg-error.spec
1 %define __strip %{_mingw_strip}
2 %define __objdump %{_mingw_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw_findrequires}
5 %define __find_provides %{_mingw_findprovides}
6
7 Name:           mingw-libgpg-error
8 Version:        1.6
9 Release:        5%{?dist}
10 Summary:        MinGW Windows GnuPGP error library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            ftp://ftp.gnupg.org/GnuPG/libgpg-error
15 Source0:        ftp://ftp.gnupg.org/GnuPG/libgpg-error/libgpg-error-%{version}.tar.bz2
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildArch:      noarch
18
19 BuildRequires:  mingw-filesystem >= 23
20 BuildRequires:  mingw-gcc
21 BuildRequires:  mingw-binutils
22 BuildRequires:  mingw-gettext
23
24 %description
25 MinGW Windows GnuPGP error library.
26
27
28 %prep
29 %setup -q -n libgpg-error-%{version}
30
31
32 %build
33 %{_mingw_configure}
34 make
35
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 make DESTDIR=$RPM_BUILD_ROOT install
41
42 rm $RPM_BUILD_ROOT%{_mingw_libdir}/libgpg-error.a
43
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48
49 %files
50 %defattr(-,root,root)
51 %{_mingw_bindir}/gpg-error-config
52 %{_mingw_bindir}/gpg-error.exe
53 %{_mingw_bindir}/libgpg-error-0.dll
54 %{_mingw_libdir}/libgpg-error.dll.a
55 %{_mingw_libdir}/libgpg-error.la
56 %{_mingw_includedir}/gpg-error.h
57 %{_mingw_datadir}/locale/*/LC_MESSAGES/libgpg-error.mo
58 %{_mingw_datadir}/aclocal/gpg-error.m4
59 %{_mingw_datadir}/common-lisp/source/gpg-error/*
60
61 %changelog
62 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.6-5
63 - Remove static libraries.
64
65 * Fri Sep  5 2008 Daniel P. Berrange <berrange@redhat.com> - 1.6-4
66 - Add gettext support
67
68 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 1.6-3
69 - Use mingw-filesystem RPM macros.
70 - BuildArch is noarch.
71
72 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 1.6-2
73 - List files explicitly and use custom CFLAGS
74
75 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 1.6-1
76 - Initial RPM release, largely based on earlier work from several sources.