Don't use RPM_OPT_FLAGS because they add -m64 on x86_64 arch. List all files explicit...
[fedora-mingw.git] / libgcrypt / mingw-libgcrypt.spec
1 %define __os_install_post /usr/lib/rpm/brp-compress %{nil}
2
3 Name:           mingw-libgcrypt
4 Version:        1.4.1
5 Release:        2%{?dist}
6 Summary:        MinGW Windows gcrypt encryption library
7
8 License:        LGPLv2+
9 Group:          Development/Libraries
10 URL:            ftp://ftp.gnupg.org/gcrypt/libgcrypt/
11 Source0:        ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-%{version}.tar.bz2
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 BuildRequires:  mingw-gcc
15 BuildRequires:  mingw-binutils
16 BuildRequires:  mingw-libgpg-error
17
18 Requires:       mingw-runtime
19 Requires:       mingw-libgpg-error
20
21 %description
22 MinGW Windows gcrypt encryption library.
23
24
25 %prep
26 %setup -q -n libgcrypt-%{version}
27
28
29 %build
30 CFLAGS="-O2 -g -Wall -pipe" \
31 ./configure \
32   --build=%_build \
33   --host=i686-pc-mingw32 \
34   --prefix=%{_prefix}/i686-pc-mingw32/sys-root/mingw
35
36 make
37
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 make DESTDIR=$RPM_BUILD_ROOT install
43
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48
49 %files
50 %defattr(-,root,root)
51 %{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/dumpsexp.exe
52 %{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/libgcrypt-11.dll
53 %{_prefix}/i686-pc-mingw32/sys-root/mingw/bin/libgcrypt-config
54 %{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/libgcrypt.a
55 %{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/libgcrypt.def
56 %{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/libgcrypt.dll.a
57 %{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/libgcrypt.la
58 %{_prefix}/i686-pc-mingw32/sys-root/mingw/include/gcrypt-module.h
59 %{_prefix}/i686-pc-mingw32/sys-root/mingw/include/gcrypt.h
60 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/aclocal/libgcrypt.m4
61 %{_prefix}/i686-pc-mingw32/sys-root/mingw/share/info/gcrypt.info
62
63 %changelog
64 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 1.4.1-2
65 - List files explicitly and use custom CFLAGS
66
67 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 1.4.1-1
68 - Initial RPM release, largely based on earlier work from several sources.