Fix paths and fonts.
[fedora-mingw.git] / inkscape / mingw32-inkscape.spec
1 # NB: Not for a Fedora package, just an example to show how
2 # to build Inkscape using the cross-compiler.
3
4 %define __strip %{_mingw32_strip}
5 %define __objdump %{_mingw32_objdump}
6 %define _use_internal_dependency_generator 0
7 %define __find_requires %{_mingw32_findrequires}
8 %define __find_provides %{_mingw32_findprovides}
9
10 Name:           mingw32-inkscape
11 Version:        20081027
12 Release:        5%{?dist}
13 Summary:        MinGW Windows port of Inkscape vector graphics editor
14
15 License:        LGPLv2+
16 Group:          Development/Libraries
17 URL:            http://www.inkscape.org/
18
19 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21 # Checked out of SVN on the date shown and then just rolled up into
22 # a tarball.
23 # svn co https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk inkscape
24 # tar zcf /tmp/inkscape-%{version}.tar.gz inkscape
25 Source0:        inkscape-%{version}.tar.gz
26
27 # Rolled-up source patch, submitted upstream on 2008-10-27.
28 Patch0:         mingw32-inkscape-20081027.patch
29
30 # Fix the paths.
31 Patch1:         mingw32-inkscape-20081027-paths.patch
32
33 # This patch is only needed to run under Wine, which doesn't
34 # supported getting the outline of unhinted fonts.
35 Patch2:         /mingw32-inkscape-20081027-unhinted-fonts-for-wine.patch
36
37 BuildArch:      noarch
38
39 BuildRequires:  mingw32-filesystem >= 30
40 BuildRequires:  mingw32-gcc
41 BuildRequires:  mingw32-gcc-c++
42 BuildRequires:  mingw32-binutils
43 BuildRequires:  mingw32-fontconfig
44 BuildRequires:  mingw32-freetype
45 BuildRequires:  mingw32-glibmm24
46 BuildRequires:  mingw32-cairomm
47 BuildRequires:  mingw32-pangomm
48 BuildRequires:  mingw32-gtkmm24
49 BuildRequires:  mingw32-popt
50 BuildRequires:  mingw32-libxml2
51 BuildRequires:  mingw32-libxslt
52 BuildRequires:  mingw32-gc
53 BuildRequires:  mingw32-gsl
54 BuildRequires:  mingw32-boost
55 BuildRequires:  mingw32-libsigc++20
56
57 BuildRequires:  autoconf, automake, libtool, intltool
58
59 # For /usr/bin/glib-gettextize
60 BuildRequires:  glib2-devel
61
62
63 %description
64 An Open Source vector graphics editor, with capabilities similar to
65 Illustrator, CorelDraw, or Xara X, using the W3C standard Scalable
66 Vector Graphics (SVG) file format.
67
68 Inkscape supports many advanced SVG features (markers, clones, alpha
69 blending, etc.) and great care is taken in designing a streamlined
70 interface. It is very easy to edit nodes, perform complex path
71 operations, trace bitmaps and much more. We also aim to maintain a
72 thriving user and developer community by using open,
73 community-oriented development.
74
75
76 %prep
77 %setup -q -n inkscape
78 %patch0 -p0
79 %patch1 -p0
80 %patch2 -p0
81
82 ./autogen.sh
83
84
85 %build
86 PATH=%{_mingw32_bindir}:$PATH \
87 %{_mingw32_configure} \
88   --enable-lcms=no \
89   --without-gnome-vfs
90 make %{?_smp_mflags}
91
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 make DESTDIR=$RPM_BUILD_ROOT install
96
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101
102 %files
103 %defattr(-,root,root)
104 %{_mingw32_bindir}/inkscape.exe
105 %{_mingw32_bindir}/inkview.exe
106 %{_mingw32_datadir}/applications/inkscape.desktop
107 %{_mingw32_datadir}/inkscape/
108 %{_mingw32_datadir}/locale/*/LC_MESSAGES/inkscape.mo
109 %{_mingw32_datadir}/pixmaps/inkscape.png
110 %{_mingw32_mandir}/*/man1/*.1
111 %{_mingw32_mandir}/man1/*.1
112
113
114 %changelog
115 * Mon Oct 27 2008 Richard W.M. Jones <rjones@redhat.com> - 20081027-5
116 - Initial RPM release.