Updated patch.
[fedora-mingw.git] / inkscape / mingw32-inkscape.spec
1 # NB: Not for a Fedora package, just an example to show how
2 # to build Inkscape using the cross-compiler.
3
4 %define __strip %{_mingw32_strip}
5 %define __objdump %{_mingw32_objdump}
6 %define _use_internal_dependency_generator 0
7 %define __find_requires %{_mingw32_findrequires}
8 %define __find_provides %{_mingw32_findprovides}
9
10 Name:           mingw32-inkscape
11 Version:        20081027
12 Release:        2%{?dist}
13 Summary:        MinGW Windows port of Inkscape vector graphics editor
14
15 License:        LGPLv2+
16 Group:          Development/Libraries
17 URL:            http://www.inkscape.org/
18
19 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21 # Checked out of SVN on the date shown and then just rolled up into
22 # a tarball.
23 # svn co https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk inkscape
24 # tar zcf /tmp/inkscape-%{version}.tar.gz inkscape
25 Source0:        inkscape-%{version}.tar.gz
26
27 # Rolled-up source patch, submitted upstream on 2008-10-27.
28 Patch0:         mingw32-inkscape-20081027.patch
29
30 BuildArch:      noarch
31
32 BuildRequires:  mingw32-filesystem >= 30
33 BuildRequires:  mingw32-gcc
34 BuildRequires:  mingw32-gcc-c++
35 BuildRequires:  mingw32-binutils
36 BuildRequires:  mingw32-fontconfig
37 BuildRequires:  mingw32-glibmm24
38 BuildRequires:  mingw32-cairomm
39 BuildRequires:  mingw32-pangomm
40 BuildRequires:  mingw32-gtkmm24
41 BuildRequires:  mingw32-popt
42 BuildRequires:  mingw32-libxml2
43 BuildRequires:  mingw32-libxslt
44 BuildRequires:  mingw32-gc
45 BuildRequires:  mingw32-gsl
46 BuildRequires:  mingw32-boost
47 BuildRequires:  mingw32-libsigc++20
48
49 BuildRequires:  autoconf, automake, libtool
50
51
52 %description
53 An Open Source vector graphics editor, with capabilities similar to
54 Illustrator, CorelDraw, or Xara X, using the W3C standard Scalable
55 Vector Graphics (SVG) file format.
56
57 Inkscape supports many advanced SVG features (markers, clones, alpha
58 blending, etc.) and great care is taken in designing a streamlined
59 interface. It is very easy to edit nodes, perform complex path
60 operations, trace bitmaps and much more. We also aim to maintain a
61 thriving user and developer community by using open,
62 community-oriented development.
63
64
65 %prep
66 %setup -q -n inkscape
67 %patch0 -p0
68
69 ./autogen.sh
70
71
72 %build
73 %{_mingw32_configure} \
74   --enable-lcms=no \
75   --without-gnome-vfs
76 make %{?_smp_mflags}
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 make DESTDIR=$RPM_BUILD_ROOT install
82
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87
88 %files
89 %defattr(-,root,root)
90 %{_mingw32_bindir}/inkscape.exe
91 %{_mingw32_bindir}/inkview.exe
92 %{_mingw32_datadir}/applications/inkscape.desktop
93 %{_mingw32_datadir}/inkscape/
94 %{_mingw32_datadir}/locale/*/LC_MESSAGES/inkscape.mo
95 %{_mingw32_datadir}/pixmaps/inkscape.png
96 %{_mingw32_mandir}/*/man1/*.1
97 %{_mingw32_mandir}/man1/*.1
98
99
100 %changelog
101 * Mon Oct 27 2008 Richard W.M. Jones <rjones@redhat.com> - 20081027-2
102 - Initial RPM release.