Built in mock, fixed missing dependencies.
[fedora-mingw.git] / inkscape / mingw32-inkscape.spec
1 # NB: Not for a Fedora package, just an example to show how
2 # to build Inkscape using the cross-compiler.
3
4 %define __strip %{_mingw32_strip}
5 %define __objdump %{_mingw32_objdump}
6 %define _use_internal_dependency_generator 0
7 %define __find_requires %{_mingw32_findrequires}
8 %define __find_provides %{_mingw32_findprovides}
9
10 Name:           mingw32-inkscape
11 Version:        20081027
12 Release:        3%{?dist}
13 Summary:        MinGW Windows port of Inkscape vector graphics editor
14
15 License:        LGPLv2+
16 Group:          Development/Libraries
17 URL:            http://www.inkscape.org/
18
19 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21 # Checked out of SVN on the date shown and then just rolled up into
22 # a tarball.
23 # svn co https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk inkscape
24 # tar zcf /tmp/inkscape-%{version}.tar.gz inkscape
25 Source0:        inkscape-%{version}.tar.gz
26
27 # Rolled-up source patch, submitted upstream on 2008-10-27.
28 Patch0:         mingw32-inkscape-20081027.patch
29
30 BuildArch:      noarch
31
32 BuildRequires:  mingw32-filesystem >= 30
33 BuildRequires:  mingw32-gcc
34 BuildRequires:  mingw32-gcc-c++
35 BuildRequires:  mingw32-binutils
36 BuildRequires:  mingw32-fontconfig
37 BuildRequires:  mingw32-freetype
38 BuildRequires:  mingw32-glibmm24
39 BuildRequires:  mingw32-cairomm
40 BuildRequires:  mingw32-pangomm
41 BuildRequires:  mingw32-gtkmm24
42 BuildRequires:  mingw32-popt
43 BuildRequires:  mingw32-libxml2
44 BuildRequires:  mingw32-libxslt
45 BuildRequires:  mingw32-gc
46 BuildRequires:  mingw32-gsl
47 BuildRequires:  mingw32-boost
48 BuildRequires:  mingw32-libsigc++20
49
50 BuildRequires:  autoconf, automake, libtool, intltool
51
52 # For /usr/bin/glib-gettextize
53 BuildRequires:  glib2-devel
54
55
56 %description
57 An Open Source vector graphics editor, with capabilities similar to
58 Illustrator, CorelDraw, or Xara X, using the W3C standard Scalable
59 Vector Graphics (SVG) file format.
60
61 Inkscape supports many advanced SVG features (markers, clones, alpha
62 blending, etc.) and great care is taken in designing a streamlined
63 interface. It is very easy to edit nodes, perform complex path
64 operations, trace bitmaps and much more. We also aim to maintain a
65 thriving user and developer community by using open,
66 community-oriented development.
67
68
69 %prep
70 %setup -q -n inkscape
71 %patch0 -p0
72
73 ./autogen.sh
74
75
76 %build
77 PATH=%{_mingw32_bindir}:$PATH \
78 %{_mingw32_configure} \
79   --enable-lcms=no \
80   --without-gnome-vfs
81 make %{?_smp_mflags}
82
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 make DESTDIR=$RPM_BUILD_ROOT install
87
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92
93 %files
94 %defattr(-,root,root)
95 %{_mingw32_bindir}/inkscape.exe
96 %{_mingw32_bindir}/inkview.exe
97 %{_mingw32_datadir}/applications/inkscape.desktop
98 %{_mingw32_datadir}/inkscape/
99 %{_mingw32_datadir}/locale/*/LC_MESSAGES/inkscape.mo
100 %{_mingw32_datadir}/pixmaps/inkscape.png
101 %{_mingw32_mandir}/*/man1/*.1
102 %{_mingw32_mandir}/man1/*.1
103
104
105 %changelog
106 * Mon Oct 27 2008 Richard W.M. Jones <rjones@redhat.com> - 20081027-3
107 - Initial RPM release.