Enable C++ compilers. Split cpp & c++ into sub-RPMs. Add gettext and iconv
[fedora-mingw.git] / gnutls-fragment / gnutls-original.spec
1 Summary: A TLS protocol implementation
2 Name: gnutls
3 Version: 2.4.1
4 Release: 1%{?dist}
5 # The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
6 License: GPLv3+ and LGPLv2+
7 Group: System Environment/Libraries
8 BuildRequires: libgcrypt-devel >= 1.2.2, gettext
9 BuildRequires: zlib-devel, readline-devel, libtasn1-devel
10 BuildRequires: lzo-devel
11 URL: http://www.gnutls.org/
12 #Source0: ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz
13 #Source1: ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz.sig
14 # XXX patent tainted SRP code removed.
15 Source0: %{name}-%{version}-nosrp.tar.bz2
16 Source1: libgnutls-config
17 Patch1: gnutls-2.4.0-nosrp.patch
18
19 BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20 Requires: libgcrypt >= 1.2.2
21
22 %package devel
23 Summary: Development files for the %{name} package
24 Group: Development/Libraries
25 Requires: %{name} = %{version}-%{release}
26 Requires: libgcrypt-devel
27 Requires: pkgconfig
28 Requires(post): /sbin/install-info
29 Requires(preun): /sbin/install-info
30
31 %package utils
32 Summary: Command line tools for TLS protocol
33 Group: Applications/System
34 Requires: %{name} = %{version}-%{release}
35
36 %description
37 GnuTLS is a project that aims to develop a library which provides a secure 
38 layer, over a reliable transport layer. Currently the GnuTLS library implements
39 the proposed standards by the IETF's TLS working group.
40
41 %description devel
42 GnuTLS is a project that aims to develop a library which provides a secure
43 layer, over a reliable transport layer. Currently the GnuTLS library implements
44 the proposed standards by the IETF's TLS working group.
45 This package contains files needed for developing applications with
46 the GnuTLS library.
47
48 %description utils
49 GnuTLS is a project that aims to develop a library which provides a secure
50 layer, over a reliable transport layer. Currently the GnuTLS library implements
51 the proposed standards by the IETF's TLS working group.
52 This package contains command line TLS client and server and certificate
53 manipulation tools.
54
55 %prep
56 %setup -q
57 %patch1 -p1 -b .nosrp
58
59 for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
60     touch lib/$i
61 done
62
63 %build
64 %configure --with-libtasn1-prefix=%{_prefix} \
65            --with-included-libcfg \
66            --disable-srp-authentication
67 make
68
69 %install
70 rm -fr $RPM_BUILD_ROOT
71 %makeinstall
72 rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
73 rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
74 cp -f %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/libgnutls-config
75 cp -f %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/libgnutls-extra-config
76 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
77 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
78 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
79 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
80 %find_lang %{name}
81
82 %check
83 make check
84
85 %clean
86 rm -fr $RPM_BUILD_ROOT
87
88 %post -p /sbin/ldconfig
89
90 %postun -p /sbin/ldconfig
91
92 %post devel
93 if [ -f %{_infodir}/gnutls.info.gz ]; then
94     /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
95 fi
96
97 %preun devel
98 if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
99    /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
100 fi
101
102 %files -f %{name}.lang
103 %defattr(-,root,root,-)
104 %{_libdir}/*.so.*
105 %doc COPYING COPYING.LIB README AUTHORS
106
107 %files devel
108 %defattr(-,root,root,-)
109 %{_bindir}/libgnutls*-config
110 %{_includedir}/*
111 %{_libdir}/*.a
112 %{_libdir}/*.so
113 %{_datadir}/aclocal/*
114 %{_libdir}/pkgconfig/*.pc
115 %{_mandir}/man3/*
116 %{_infodir}/gnutls*
117
118 %files utils
119 %defattr(-,root,root,-)
120 %{_bindir}/certtool
121 %{_bindir}/psktool
122 %{_bindir}/gnutls*
123 %{_mandir}/man1/*
124
125 %changelog
126 * Tue Jul  1 2008 Tomas Mraz <tmraz@redhat.com> 2.4.1-1
127 - new upstream version
128 - correct the license tag
129 - explicit --with-included-opencdk not needed
130 - use external lzo library, internal not included anymore
131
132 * Tue Jun 24 2008 Tomas Mraz <tmraz@redhat.com> 2.4.0-1
133 - upgrade to latest upstream
134
135 * Tue May 20 2008 Tomas Mraz <tmraz@redhat.com> 2.0.4-3
136 - fix three security issues in gnutls handshake - GNUTLS-SA-2008-1
137   (#447461, #447462, #447463)
138
139 * Mon Feb  4 2008 Joe Orton <jorton@redhat.com> 2.0.4-2
140 - use system libtasn1
141
142 * Tue Dec  4 2007 Tomas Mraz <tmraz@redhat.com> 2.0.4-1
143 - upgrade to latest upstream
144
145 * Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> 1.6.3-2
146 - license tag fix
147
148 * Wed Jun  6 2007 Tomas Mraz <tmraz@redhat.com> 1.6.3-1
149 - upgrade to latest upstream (#232445)
150
151 * Tue Apr 10 2007 Tomas Mraz <tmraz@redhat.com> 1.4.5-2
152 - properly require install-info (patch by Ville Skyttä)
153 - standard buildroot and use dist tag
154 - add COPYING and README to doc
155
156 * Wed Feb  7 2007 Tomas Mraz <tmraz@redhat.com> 1.4.5-1
157 - new upstream version
158 - drop libtermcap-devel from buildrequires
159
160 * Thu Sep 14 2006 Tomas Mraz <tmraz@redhat.com> 1.4.1-2
161 - detect forged signatures - CVE-2006-4790 (#206411), patch
162   from upstream
163
164 * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 1.4.1-1
165 - upgrade to new upstream version, only minor changes
166
167 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.4.0-1.1
168 - rebuild
169
170 * Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.4.0-1
171 - upgrade to new upstream version (#192070), rebuild
172   of dependent packages required
173
174 * Tue May 16 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.10-2
175 - added missing buildrequires
176
177 * Mon Feb 13 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.10-1
178 - updated to new version (fixes CVE-2006-0645)
179
180 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-3.2
181 - bump again for double-long bug on ppc(64)
182
183 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-3.1
184 - rebuilt for new gcc4.1 snapshot and glibc changes
185
186 * Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.9-3
187 - rebuilt
188
189 * Fri Dec  9 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-2
190 - replaced *-config scripts with calls to pkg-config to
191   solve multilib conflicts
192
193 * Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-1
194 - upgrade to newest upstream
195 - removed .la files (#172635)
196
197 * Sun Aug  7 2005 Tomas Mraz <tmraz@redhat.com> 1.2.6-1
198 - upgrade to newest upstream (rebuild of dependencies necessary)
199
200 * Mon Jul  4 2005 Tomas Mraz <tmraz@redhat.com> 1.0.25-2
201 - split the command line tools to utils subpackage
202
203 * Sat Apr 30 2005 Tomas Mraz <tmraz@redhat.com> 1.0.25-1
204 - new upstream version fixes potential DOS attack
205
206 * Sat Apr 23 2005 Tomas Mraz <tmraz@redhat.com> 1.0.24-2
207 - readd the version script dropped by upstream
208
209 * Fri Apr 22 2005 Tomas Mraz <tmraz@redhat.com> 1.0.24-1
210 - update to the latest upstream version on the 1.0 branch
211
212 * Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
213 - gcc4 rebuild
214
215 * Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
216 - add gnutls Requires zlib-devel (#144069)
217
218 * Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
219 - Make gnutls-devel Require libgcrypt-devel
220
221 * Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
222 - rebuild with release++, otherwise unchanged.
223
224 * Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
225 - patent tainted SRP code removed.
226
227 * Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
228 - update to 1.0.20.
229 - add --with-included-opencdk --with-included-libtasn1
230 - add --with-included-libcfg --with-included-lzo
231 - add --disable-srp-authentication.
232 - do "make check" after build.
233
234 * Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
235 - upgrade to 0.9.2
236
237 * Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
238 - update to 0.4.4.
239
240 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
241 - automated rebuild
242
243 * Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
244 - update to 0.4.3.
245
246 * Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
247 - update to 0.4.2.
248 - change license to LGPL.
249 - include splint annotations patch.
250
251 * Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
252 - update to 0.4.0
253
254 * Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
255 - update to 0.3.2
256
257 * Wed Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
258 - add a URL
259
260 * Wed Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
261 - initial package