Ugh, Mercurial is stupid.
[fedora-mingw.git] / gdb / mingw-gdb.spec
1 Name:           mingw-gdb
2 Version:        6.8
3 Release:        1%{?dist}
4 Summary:        MinGW port of the GNU debugger (gdb)
5
6 License:        GPLv2+
7 Group:          Development/Libraries
8 URL:            http://www.mingw.org/MinGWiki/index.php/gdb
9 Source0:        http://dl.sourceforge.net/sourceforge/mingw/gdb-%{version}-mingw-src.tar.gz
10 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12 Patch0:         mingw-gdb-6.8-no-getcwd-error.patch
13
14 BuildRequires:  mingw-filesystem >= 23
15 BuildRequires:  flex
16 BuildRequires:  chrpath
17
18 Requires:       mingw-filesystem >= 23
19 Requires:       mingw-binutils
20 Requires:       mingw-runtime
21
22
23 %description
24 This is the MinGW port of the GNU debugger (gdb).
25
26 Note this is a Fedora native binary which debugs Windows target
27 executables.
28
29
30 %prep
31 %setup -q -n gdb-%{version}
32 %patch0 -p1
33
34
35 %build
36 %{_mingw_configure}
37 make
38
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 make DESTDIR=$RPM_BUILD_ROOT install
43
44 # Remove files that clash with other installed stuff.
45 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
46 rm -rf $RPM_BUILD_ROOT%{_infodir}/*
47 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
48
49 # Remove rpaths
50 chrpath --delete $RPM_BUILD_ROOT%{_bindir}/*
51
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56
57 %files
58 %defattr(-,root,root)
59 %{_bindir}/i686-pc-mingw32-gdb
60 %{_bindir}/i686-pc-mingw32-gdbtui
61 %{_mandir}/man1/*.1*
62
63
64 %changelog
65 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 6.8-1
66 - Initial RPM release.