mingw -> mingw32 rename and miscellanous related fixes.
[fedora-mingw.git] / filesystem / mingw32-filesystem.spec
1 %define debug_package %{nil}
2
3 Name:           mingw32-filesystem
4 Version:        27
5 Release:        1%{?dist}
6 Summary:        MinGW base filesystem and environment
7
8 Group:          Development/Libraries
9 License:        GPLv2+
10 URL:            http://hg.et.redhat.com/misc/fedora-mingw--devel/
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildArch:      noarch
13
14 Source0:        mingw32-COPYING
15 Source1:        mingw32-macros.mingw32
16 Source2:        mingw32.sh
17 Source3:        mingw32.csh
18 Source4:        mingw32-find-requires.sh
19 Source5:        mingw32-find-provides.sh
20
21 Requires:       setup
22 Requires:       rpm
23
24 # These are actually provided by Windows itself, or Wine.
25 Provides:       mingw32(gdi32.dll)
26 Provides:       mingw32(kernel32.dll)
27 Provides:       mingw32(ole32.dll)
28 Provides:       mingw32(mscoree.dll)
29 Provides:       mingw32(msvcrt.dll)
30 Provides:       mingw32(user32.dll)
31
32 Obsoletes:      mingw-filesystem = %{version}-%{release}
33 Provides:       mingw-filesystem < 26
34
35
36 %description
37 This package contains the base filesystem layout, RPM macros and
38 environment for all Fedora MinGW packages.
39
40 This environment is maintained by the Fedora MinGW SIG at:
41
42   http://fedoraproject.org/wiki/SIGs/MinGW
43
44
45 %prep
46 %setup -q -c -T
47 cp %{SOURCE0} COPYING
48 sed 's/@VERSION@/%{version}/' < %{SOURCE4} > mingw32-find-requires.sh
49
50
51 %build
52 # nothing
53
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 mkdir -p $RPM_BUILD_ROOT
59
60 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
61 install -m 644 %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
62
63 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
64 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.mingw32
65
66 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32
67
68 # GCC requires these directories, even though they contain links
69 # to binaries which are also installed in /usr/bin etc.  These
70 # contain Fedora native binaries.
71 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/bin
72 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/lib
73
74 # The MinGW system root which will contain Windows native binaries
75 # and Windows-specific header files, pkgconfig, etc.
76 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw
77 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin
78 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include
79 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/sys
80 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib
81 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/pkgconfig
82
83 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/aclocal
84
85 # We don't normally package manual pages and info files, except
86 # where those are not supplied by a Fedora native package.  So we
87 # need to create the directories.
88 #
89 # Note that some packages try to install stuff in
90 #   /usr/i686-pc-mingw32/sys-root/mingw/man and
91 #   /usr/i686-pc-mingw32/sys-root/mingw/doc
92 # but those are both packaging bugs.
93 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share
94 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/doc
95 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/info
96 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man
97 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man/man{1,2,3,4,5,6,7,8,l,n}
98
99 # NB. NOT _libdir
100 mkdir -p $RPM_BUILD_ROOT/usr/lib/rpm
101 install -m 0755 mingw32-find-requires.sh $RPM_BUILD_ROOT/usr/lib/rpm
102 install -m 0755 %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/rpm
103
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108
109 %files
110 %defattr(-,root,root,-)
111 %doc COPYING
112 %config(noreplace) %{_sysconfdir}/rpm/macros.mingw32
113 %config(noreplace) %{_sysconfdir}/profile.d/mingw32.sh
114 %config(noreplace) %{_sysconfdir}/profile.d/mingw32.csh
115 %{_prefix}/i686-pc-mingw32/
116 /usr/lib/rpm/mingw32-*
117
118
119 %changelog
120 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 27-1
121 - Begin the grand renaming of mingw -> mingw32.
122 - Added mingw32(mscoree.dll).
123
124 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 25-1
125 - Add shared aclocal directory.
126
127 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 24-1
128 - Remove mingw-defs, since no longer used.
129 - Add _mingw_infodir.
130
131 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 23-1
132 - Add macros for find-provides/requires scripts
133
134 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 22-1
135 - Windows provides OLE32.DLL.
136
137 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 21-1
138 - Allow '.' in dll names for find-requires
139 - Windows provides GDI32.DLL.
140
141 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 20-1
142 - On 64 bit install in /usr/lib/rpm always.
143
144 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 19-1
145 - 'user32.dll' is provided by Windows.
146 - Allow '-' in DLL names.
147 - More accurate detection of DLLs in requires/provides scripts.
148
149 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 17-1
150 - Automatically add mingw-filesystem and mingw-runtime requires.
151 - Add --prefix to _mingw_configure macro.
152 - Three backslashes required on each continuation line in RPM macros.
153
154 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 14-1
155 - Fix path to mingw-find-requires/provides scripts.
156
157 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 12-1
158 - Put CFLAGS on a single line to avoid problems in some configure scripts.
159
160 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 10-1
161 - Provides certain base Windows DLLs (not literally).
162
163 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 9-1
164 - Include RPM dependency generators and definitions.
165
166 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 4-1
167 - Add _mingw_cc/cflags/etc. and _mingw_configure macros.
168
169 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3-1
170 - Add _mingw_host macro.
171
172 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 2-1
173 - Add _mingw_sysroot macro.
174 - Add _mingw_target macro.
175
176 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 1-1
177 - Basic filesystem layout.