Moved ole32.dll provides from w32api -> filesystem.
[fedora-mingw.git] / filesystem / mingw-filesystem.spec
1 %define debug_package %{nil}
2
3 Name:           mingw-filesystem
4 Version:        22
5 Release:        1%{?dist}
6 Summary:        MinGW base filesystem and environment
7
8 Group:          Development/Libraries
9 License:        GPLv2+
10 URL:            http://hg.et.redhat.com/misc/fedora-mingw--devel/
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildArch:      noarch
13
14 Source0:        mingw-COPYING
15 Source1:        mingw-macros.mingw
16 Source2:        mingw.sh
17 Source3:        mingw.csh
18 Source4:        mingw-find-requires.sh
19 Source5:        mingw-find-provides.sh
20 Source6:        mingw-defs
21
22 Requires:       setup
23 Requires:       rpm
24
25 # These are actually provided by Windows itself, or Wine.
26 Provides:       mingw(msvcrt.dll)
27 Provides:       mingw(kernel32.dll)
28 Provides:       mingw(user32.dll)
29 Provides:       mingw(gdi32.dll)
30 Provides:       mingw(ole32.dll)
31
32
33 %description
34 This package contains the base filesystem layout, RPM macros and
35 environment for all Fedora MinGW packages.
36
37 This environment is maintained by the Fedora MinGW SIG at:
38
39   http://fedoraproject.org/wiki/SIGs/MinGW
40
41
42 %prep
43 %setup -q -c -T
44 cp %{SOURCE0} COPYING
45 sed 's/@VERSION@/%{version}/' < %{SOURCE4} > mingw-find-requires.sh
46
47
48 %build
49 # nothing
50
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 mkdir -p $RPM_BUILD_ROOT
56
57 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
58 install -m 644 %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
59
60 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
61 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.mingw
62
63 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32
64
65 # GCC requires these directories, even though they contain links
66 # to binaries which are also installed in /usr/bin etc.  These
67 # contain Fedora native binaries.
68 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/bin
69 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/lib
70
71 # The MinGW system root which will contain Windows native binaries
72 # and Windows-specific header files, man pages, pkgconfig, etc.
73 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw
74 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin
75 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/doc
76 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include
77 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/sys
78 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib
79 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/pkgconfig
80 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share
81 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/doc
82 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man
83 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man/man{1,2,3,4,5,6,7,8,l,n}
84
85 # Note that some packages try to install in
86 # /usr/i686-pc-mingw32/sys-root/mingw/man and
87 # /usr/i686-pc-mingw32/sys-root/mingw/doc
88 # but these are both packaging bugs.
89
90 # NB. NOT libdir
91 mkdir -p $RPM_BUILD_ROOT/usr/lib/rpm
92 install -m 0755 mingw-find-requires.sh $RPM_BUILD_ROOT/usr/lib/rpm
93 install -m 0755 %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/rpm
94 install -m 0644 %{SOURCE6} $RPM_BUILD_ROOT/usr/lib/rpm
95
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100
101 %files
102 %defattr(-,root,root,-)
103 %doc COPYING
104 %config(noreplace) %{_sysconfdir}/rpm/macros.mingw
105 %config(noreplace) %{_sysconfdir}/profile.d/mingw.sh
106 %config(noreplace) %{_sysconfdir}/profile.d/mingw.csh
107 %{_prefix}/i686-pc-mingw32/
108 /usr/lib/rpm/mingw-*
109
110
111 %changelog
112 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 22-1
113 - Windows provides OLE32.DLL.
114
115 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 21-1
116 - Allow '.' in dll names for find-requires
117 - Windows provides GDI32.DLL.
118
119 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 20-1
120 - On 64 bit install in /usr/lib/rpm always.
121
122 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 19-1
123 - 'user32.dll' is provided by Windows.
124 - Allow '-' in DLL names.
125 - More accurate detection of DLLs in requires/provides scripts.
126
127 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 17-1
128 - Automatically add mingw-filesystem and mingw-runtime requires.
129 - Add --prefix to _mingw_configure macro.
130 - Three backslashes required on each continuation line in RPM macros.
131
132 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 14-1
133 - Fix path to mingw-find-requires/provides scripts.
134
135 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 12-1
136 - Put CFLAGS on a single line to avoid problems in some configure scripts.
137
138 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 10-1
139 - Provides certain base Windows DLLs (not literally).
140
141 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 9-1
142 - Include RPM dependency generators and definitions.
143
144 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 4-1
145 - Add _mingw_cc/cflags/etc. and _mingw_configure macros.
146
147 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3-1
148 - Add _mingw_host macro.
149
150 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 2-1
151 - Add _mingw_sysroot macro.
152 - Add _mingw_target macro.
153
154 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 1-1
155 - Basic filesystem layout.