Add %{_mingw_infodir}.
[fedora-mingw.git] / filesystem / mingw-filesystem.spec
1 %define debug_package %{nil}
2
3 Name:           mingw-filesystem
4 Version:        24
5 Release:        1%{?dist}
6 Summary:        MinGW base filesystem and environment
7
8 Group:          Development/Libraries
9 License:        GPLv2+
10 URL:            http://hg.et.redhat.com/misc/fedora-mingw--devel/
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildArch:      noarch
13
14 Source0:        mingw-COPYING
15 Source1:        mingw-macros.mingw
16 Source2:        mingw.sh
17 Source3:        mingw.csh
18 Source4:        mingw-find-requires.sh
19 Source5:        mingw-find-provides.sh
20
21 Requires:       setup
22 Requires:       rpm
23
24 # These are actually provided by Windows itself, or Wine.
25 Provides:       mingw(msvcrt.dll)
26 Provides:       mingw(kernel32.dll)
27 Provides:       mingw(user32.dll)
28 Provides:       mingw(gdi32.dll)
29 Provides:       mingw(ole32.dll)
30
31
32 %description
33 This package contains the base filesystem layout, RPM macros and
34 environment for all Fedora MinGW packages.
35
36 This environment is maintained by the Fedora MinGW SIG at:
37
38   http://fedoraproject.org/wiki/SIGs/MinGW
39
40
41 %prep
42 %setup -q -c -T
43 cp %{SOURCE0} COPYING
44 sed 's/@VERSION@/%{version}/' < %{SOURCE4} > mingw-find-requires.sh
45
46
47 %build
48 # nothing
49
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 mkdir -p $RPM_BUILD_ROOT
55
56 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
57 install -m 644 %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
58
59 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
60 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.mingw
61
62 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32
63
64 # GCC requires these directories, even though they contain links
65 # to binaries which are also installed in /usr/bin etc.  These
66 # contain Fedora native binaries.
67 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/bin
68 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/lib
69
70 # The MinGW system root which will contain Windows native binaries
71 # and Windows-specific header files, pkgconfig, etc.
72 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw
73 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin
74 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include
75 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/sys
76 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib
77 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/pkgconfig
78
79 # We don't normally package manual pages and info files, except
80 # where those are not supplied by a Fedora native package.  So we
81 # need to create the directories.
82 #
83 # Note that some packages try to install stuff in
84 #   /usr/i686-pc-mingw32/sys-root/mingw/man and
85 #   /usr/i686-pc-mingw32/sys-root/mingw/doc
86 # but those are both packaging bugs.
87 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share
88 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/doc
89 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/info
90 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man
91 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man/man{1,2,3,4,5,6,7,8,l,n}
92
93 # NB. NOT _libdir
94 mkdir -p $RPM_BUILD_ROOT/usr/lib/rpm
95 install -m 0755 mingw-find-requires.sh $RPM_BUILD_ROOT/usr/lib/rpm
96 install -m 0755 %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/rpm
97
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102
103 %files
104 %defattr(-,root,root,-)
105 %doc COPYING
106 %config(noreplace) %{_sysconfdir}/rpm/macros.mingw
107 %config(noreplace) %{_sysconfdir}/profile.d/mingw.sh
108 %config(noreplace) %{_sysconfdir}/profile.d/mingw.csh
109 %{_prefix}/i686-pc-mingw32/
110 /usr/lib/rpm/mingw-*
111
112
113 %changelog
114 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 24-1
115 - Remove mingw-defs, since no longer used.
116 - Add _mingw_infodir.
117
118 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 23-1
119 - Add macros for find-provides/requires scripts
120
121 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 22-1
122 - Windows provides OLE32.DLL.
123
124 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 21-1
125 - Allow '.' in dll names for find-requires
126 - Windows provides GDI32.DLL.
127
128 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 20-1
129 - On 64 bit install in /usr/lib/rpm always.
130
131 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 19-1
132 - 'user32.dll' is provided by Windows.
133 - Allow '-' in DLL names.
134 - More accurate detection of DLLs in requires/provides scripts.
135
136 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 17-1
137 - Automatically add mingw-filesystem and mingw-runtime requires.
138 - Add --prefix to _mingw_configure macro.
139 - Three backslashes required on each continuation line in RPM macros.
140
141 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 14-1
142 - Fix path to mingw-find-requires/provides scripts.
143
144 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 12-1
145 - Put CFLAGS on a single line to avoid problems in some configure scripts.
146
147 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 10-1
148 - Provides certain base Windows DLLs (not literally).
149
150 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 9-1
151 - Include RPM dependency generators and definitions.
152
153 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 4-1
154 - Add _mingw_cc/cflags/etc. and _mingw_configure macros.
155
156 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3-1
157 - Add _mingw_host macro.
158
159 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 2-1
160 - Add _mingw_sysroot macro.
161 - Add _mingw_target macro.
162
163 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 1-1
164 - Basic filesystem layout.