Include LICENSE file (freedesktop bug 19582).
[fedora-mingw.git] / dlfcn / mingw32-dlfcn.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 %define realname dlfcn-win32
8
9 %define alphatag r11
10
11 Name:          mingw32-dlfcn
12 Version:       0
13 Release:       0.3.%{alphatag}%{?dist}
14 Summary:       Implements a wrapper for dlfcn (dlopen dlclose dlsym dlerror)
15
16 License:       LGPLv2+
17 Group:         Development/Libraries
18 URL:           http://code.google.com/p/dlfcn-win32/
19 Source0:       http://dlfcn-win32.googlecode.com/files/%{realname}-%{alphatag}.tar.bz2
20 BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21
22 BuildArch:     noarch
23
24 BuildRequires: mingw32-filesystem >= 40
25 BuildRequires: mingw32-gcc
26 BuildRequires: mingw32-binutils
27 #BuildRequires: dos2unix
28
29 Patch1:        dlfcn_configure.patch
30
31
32 %description
33 This library implements a wrapper for dlfcn, as specified in POSIX and SUS,
34 around the dynamic link library functions found in the Windows API.
35
36
37 %prep
38 %setup -q -n %{realname}-%{alphatag}
39
40 %{__sed} -i 's/\r//' configure
41 %{__sed} -i 's/\r//' README
42 %{__sed} -i 's/\r//' COPYING
43
44 %patch1 -p1
45
46
47 %build
48 %{_mingw32_configure} \
49   --incdir=%{_mingw32_includedir} \
50   --cc=i686-pc-mingw32-gcc \
51   --enable-shared=yes \
52   --enable-static=no \
53   --enable-strip=i686-pc-mingw32-strip
54 make %{?_smp_mflags}
55
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65
66 %files
67 %defattr(-,root,root)
68 %doc README COPYING
69 %{_mingw32_bindir}/libdl.dll
70 %{_mingw32_libdir}/libdl.dll.a
71 %{_mingw32_includedir}/dlfcn.h
72
73
74 %changelog
75 * Wed Jan 14 2009 Richard W.M. Jones <rjones@redhat.com> - 0-0.3.r11
76 - Use Version 0
77   (https://www.redhat.com/archives/fedora-packaging/2009-January/msg00064.html)
78 - Revert use of dos2unix for now
79   (https://www.redhat.com/archives/fedora-packaging/2009-January/msg00066.html)
80 - Use _smp_mflags.
81
82 * Tue Jan 13 2009 Richard W.M. Jones <rjones@redhat.com> - 0.1-0.2.r11
83 - Import into fedora-mingw temporary repository because there are packages
84   which will depend on this.
85 - Fix the version/release according to packaging guidelines.
86 - Tidy up the spec file.
87 - Use dos2unix and keep the timestamps.
88
89 * Fri Jan 02 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - r11-1
90 - Initial RPM release.