1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
10 Summary: MinGW Windows C++ API for the cairo graphics library
13 Group: Development/Libraries
14 URL: http://www.cairographics.org
15 Source0: http://www.cairographics.org/releases/cairomm-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20 BuildRequires: mingw32-filesystem >= 30
21 BuildRequires: mingw32-gcc
22 BuildRequires: mingw32-gcc-c++
23 BuildRequires: mingw32-binutils
24 BuildRequires: mingw32-cairo
25 BuildRequires: pkgconfig
31 Cairomm is the C++ API for the cairo graphics library. It offers all the power
32 of cairo with an interface familiar to C++ developers, including use of the
33 Standard Template Library where it makes sense.
37 %setup -q -n cairomm-%{version}
41 %{_mingw32_configure} --enable-static=no --enable-docs=no
46 rm -rf $RPM_BUILD_ROOT
47 make DESTDIR=$RPM_BUILD_ROOT install
51 rm -rf $RPM_BUILD_ROOT
56 %{_mingw32_bindir}/libcairomm-1.0-1.dll
57 %{_mingw32_libdir}/libcairomm-1.0.dll.a
58 %{_mingw32_libdir}/libcairomm-1.0.la
59 %{_mingw32_libdir}/pkgconfig/cairomm-1.0.pc
60 %{_mingw32_includedir}/cairomm-1.0
64 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.6.2-3
67 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.6.2-2
68 - Initial RPM release.