d1f3c6f79753a070c9fde4b07b7156e7b1f5d33a
[fedora-mingw.git] / cairo / mingw32-cairo.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-cairo
8 Version:        1.8.0
9 Release:        3%{?dist}
10 Summary:        MinGW Windows Cairo library
11
12 License:        LGPLv2 or MPLv1.1
13 URL:            http://cairographics.org
14 Source0:        http://cairographics.org/snapshots/cairo-%{version}.tar.gz
15 Group:          Development/Libraries
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 23
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-binutils
23 BuildRequires:  mingw32-libxml2
24 BuildRequires:  mingw32-pixman
25 BuildRequires:  mingw32-libpng
26 BuildRequires:  mingw32-dlfcn
27 BuildRequires:  mingw32-iconv
28 BuildRequires:  mingw32-zlib
29 BuildRequires:  pkgconfig
30
31 # These are BRs for the base package, but are not needed on Win32
32 # because Cairo includes a separate Win32 font rendering back end
33 # (thanks to: Erik van Pienbroek).
34 #BuildRequires:  mingw32-fontconfig
35 #BuildRequires:  mingw32-freetype
36
37
38 %description
39 MinGW Windows Cairo library.
40
41
42 %prep
43 %setup -q -n cairo-%{version}
44
45
46 %build
47 %{_mingw32_configure} \
48   --disable-xlib \
49   --disable-xcb \
50   --enable-win32 \
51   --enable-png \
52   --disable-static
53 make %{?_smp_mflags}
54
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61 rm -f $RPM_BUILD_ROOT%{_mingw32_libdir}/charset.alias
62
63 # If mingw32-freetype was installed, then cairo will incorrectly
64 # install the following file.  Remove it:
65 rm -f $RPM_BUILD_ROOT%{_mingw32_libdir}/pkgconfig/cairo-ft.pc
66
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71
72 %files
73 %defattr(-,root,root)
74 %doc COPYING COPYING-LGPL-2.1 COPYING-MPL-1.1
75 %{_mingw32_bindir}/libcairo-2.dll
76 %{_mingw32_includedir}/cairo/
77 %{_mingw32_libdir}/libcairo.dll.a
78 %{_mingw32_libdir}/libcairo.la
79 %{_mingw32_libdir}/pkgconfig/cairo-pdf.pc
80 %{_mingw32_libdir}/pkgconfig/cairo-png.pc
81 %{_mingw32_libdir}/pkgconfig/cairo-ps.pc
82 %{_mingw32_libdir}/pkgconfig/cairo-svg.pc
83 %{_mingw32_libdir}/pkgconfig/cairo-win32-font.pc
84 %{_mingw32_libdir}/pkgconfig/cairo-win32.pc
85 %{_mingw32_libdir}/pkgconfig/cairo.pc
86 %{_mingw32_datadir}/gtk-doc/html/cairo/
87
88
89 %changelog
90 * Mon Jan 19 2009 Richard W.M. Jones <rjones@redhat.com> - 1.8.0-3
91 - Include license file in documentation section.
92 - Disable building static library to save time.
93 - Remove BRs on mingw32-fontconfig and mingw32-freetype which are
94   not needed on Win32.
95 - Use _smp_mflags.
96 - Added BRs mingw32-dlfcn, mingw32-iconv, mingw32-zlib.
97
98 * Wed Oct 29 2008 Richard W.M. Jones <rjones@redhat.com> - 1.8.0-2
99 - Fix mixed spaces/tabs in specfile.
100
101 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.8.0-1
102 - New upstream version 1.8.0.
103
104 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.7.4-4
105 - Rename mingw -> mingw32.
106
107 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 1.7.4-3
108 - Added dep on pkgconfig
109
110 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.7.4-2
111 - Remove static libraries.
112 - Fix source URL.
113
114 * Tue Sep  9 2008 Daniel P. Berrange <berrange@redhat.com> - 1.7.4-1
115 - Initial RPM release