Combine generator subdirectories into one.
[wrappi.git] / generator-macros / Makefile.am
diff --git a/generator-macros/Makefile.am b/generator-macros/Makefile.am
deleted file mode 100644 (file)
index 9d06078..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# wrappi
-# Copyright (C) 2011 Red Hat Inc.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-OCAMLPACKAGES = -package unix,camlp4.lib
-
-OCAMLCFLAGS = \
-       -g -warn-error CDEFLMPSUVYZX \
-       -I ../generator-lib $(OCAMLPACKAGES)
-OCAMLOPTFLAGS = $(OCAMLCFLAGS)
-
-noinst_SCRIPTS = pa_wrap.cmo
-
-pa_wrap.cmo: pa_wrap.ml ../generator-lib/generator_lib.cma
-       $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) \
-         -linkpkg generator_lib.cma \
-         -pp $(CAMLP4OF) \
-         -c $< -o $@
-
-%.cmi: %.mli
-       $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -c $< -o $@
-%.cmo: %.ml
-       $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -c $< -o $@
-%.cmx: %.ml
-       $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) -c $< -o $@
-
-CLEANFILES = *.cmi *.cmo *.cmx *~
-
-depend: .depend
-
-.depend: $(wildcard *.mli) $(wildcard *.ml)
-       rm -f $@ $@-t
-       $(OCAMLFIND) ocamldep -pp $(CAMLP4OF) $^ | \
-         $(SED) -e 's/ *$$//' | \
-         $(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
-         LANG=C sort > $@-t
-       mv $@-t $@
-
-include .depend
-
-SUFFIXES = .cmo .cmi .cmx .ml .mli .mll .mly