Implement cleanup functions, including 'mailto'.
[whenjobs.git] / tests / parsing / Makefile.am
index bf83ab8..3f4f17c 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
-tests = t010_load.cmo t020_simple.cmo t030_jobnames.cmo
+EXTRA_DIST = $(SOURCES) test_load.ml
+
+SOURCES = \
+       t010_load.ml \
+       t020_simple.ml \
+       t030_jobnames.ml \
+       t040_ocaml_jobnames.ml \
+       t050_cleanups.ml
+
+tests = $(SOURCES:.ml=.cmo)
 
 check_SCRIPTS = test_load $(tests)
 
@@ -33,11 +42,11 @@ test_load: test_load.cmo ../../lib/whenlib.cma
        $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -linkpkg whenlib.cma $< -o $@
 
 # Rules for all OCaml files.
-%.cmi: %.mli ../../lib/pa_when.cmo ../../lib/whenlib.cma
+%.cmi: %.mli
        $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) $(PP) -c $< -o $@
-%.cmo: %.ml ../../lib/pa_when.cmo ../../lib/whenlib.cma
+%.cmo: %.ml
        $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) $(PP) -c $< -o $@
-#%.cmx: %.ml ../../lib/pa_when.cmo ../../lib/whenlib.cma
+#%.cmx: %.ml
 #      $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) $(PP) -c $< -o $@
 
 SUFFIXES = .cmo .cmi .cmx .ml .mli .mll .mly