Rebuild tests when library changes.
[whenjobs.git] / tests / parsing / Makefile.am
index 3f4f17c..04681cb 100644 (file)
@@ -44,7 +44,7 @@ test_load: test_load.cmo ../../lib/whenlib.cma
 # Rules for all OCaml files.
 %.cmi: %.mli
        $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) $(PP) -c $< -o $@
-%.cmo: %.ml
+%.cmo: %.ml ../../lib/whenlib.cma
        $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) $(PP) -c $< -o $@
 #%.cmx: %.ml
 #      $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) $(PP) -c $< -o $@