Implement running of jobs.
[whenjobs.git] / lib / Makefile.am
index 898f204..5ab4128 100644 (file)
@@ -55,9 +55,12 @@ whenproto_aux.ml whenproto_aux.mli: whenproto.x
        $(OCAMLRPCGEN) -int int32 -hyper int64 -aux $<
 
 # Preprocessor for whenjobs files.
-pa_when.cmo: pa_when.ml whenlib.cma
-       $(OCAMLFIND) c $(OCAMLCFLAGS) \
-         -linkpkg whenlib.cma -pp $(CAMLP4OF) -c $< -o $@
+# Note that we intentionally don't want this to depend on any
+# libraries except for camlp4.lib.
+pa_when.cmo: pa_when.ml
+       $(OCAMLFIND) c -g -warn-error CDEFLMPSUVYZX \
+         -package camlp4.lib -linkpkg \
+         -pp $(CAMLP4OF) -c $< -o $@
 
 # Rules for all OCaml files.
 %.cmi: %.mli